Herbers Excel-Forum - das Archiv

UND- und ODER-Verknüpfung

Bild

Betrifft: UND- und ODER-Verknüpfung
von: Jörg

Geschrieben am: 17.12.2006 14:32:38
Hallo,
ich habe ein kleines Problem mit einer Tabelle.
Aus einer Tabelle sollen am Ende Werte ausgegeben werden. Ich habe es auch geschafft, doch leider akzeptiert Excel in einer Zelle nur 7 WENN-Bedingungen, so dass die ausgeblendete Tabelle für die Berechnung bald größer ist als die eigentliche Tabelle, da es insgesamt 16 WENN-Bedingungen für eine Zelle sind.
Kann man ODER- und UND-Bedingungen in einer WENN-Bedingung zusammenfassen oder ist das nicht möglich? Alle meine bisherigen Versuche scheiterten.
Am Beispiel:
Wenn B1="M" oder "F" oder "N" oder "T" oder "Na" oder "ST" oder "" und B7="K" dann "0" (null).
Wenn B1="Sa" oder B1="So" oder B4="FT" oder B4="AF" und B7="K8" dann Ausgabe "0" (null).
Wenn B1="Mo" oder "Di" oder "Mi" oder "Do" oder "Fr" und B7="K8" dann Ausgabe "8".
Danke für die Hilfe.
Gr. Jörg
Bild

Betrifft: ODER(Vgl1;Vgl2;Vgl...n) - Gruß owT
von: Luc:-?
Geschrieben am: 17.12.2006 14:39:36
:-?
Bild

Betrifft: AW: ODER(Vgl1;Vgl2;Vgl...n) - Gruß owT
von: Jörg

Geschrieben am: 17.12.2006 15:36:35
Ich glaube jetzt hab ich´s (zumindest bekomme ich die richtigen Ergebnisse):
(der Ansicht wegen auf 3 Zeilen)
=WENN(ODER(B$3="F";B$3="M";B$3="N";B$3="T";B$3="Na";B$3="ST";B$3="");WENN(B9="K";0;
WENN(ODER(B$1="Mo";B$1="Di";B$1="Mi";B$1="Do";B$1="Fr");WENN(UND(B$3="";B9="K8");8;
WENN(ODER(B$1="Sa";B$1="So";B$4="FT";B$4="AF");WENN(ODER(B9="K8";B9="");0);0));0)))
Danke.
Gr. Jörg
 Bild