Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert nach Monaten berechnen | Herbers Excel-Forum


Betrifft: Mittelwert nach Monaten berechnen von: edie
Geschrieben am: 08.01.2010 19:01:33

Hallo zusammen,

wiederholt stehen in der Spalte A die Monate Januar bis Juli im Format (MMM) nach unten
in der Tabelle variabel. In der Spalte B und C die jeweiligen Werte, siehe Beispieldatei.

https://www.herber.de/bbs/user/67091.xls

Nun hätte ich gerne, wenn’s geht, die Monatsmittel berechnet.

Die Summe nach Monaten wird z.B. für die Spalte B so berechnet:
'=SUMMEWENN(A:C;A3;B:B) aber der Mittelwert, wie kann der berechnet werden?

Vorab vielen Dank

Grüße

  

Betrifft: AW: Mittelwert nach Monaten berechnen von: Worti
Geschrieben am: 08.01.2010 19:12:17

Hallo edie,
zB. so

=SUMMEWENN(A:A;A3;B:B)/ZÄHLENWENN(A3:A;A)

Gruß Worti


  

Betrifft: AW: Mittelwert nach Monaten berechnen von: edie
Geschrieben am: 08.01.2010 19:16:46

Hallo Worti,

vielen Dank, leider bekomme ich nur #NAME?. Was mache ich falsch?

Grüße


  

Betrifft: AW: '=SUMMEWENN(A:A;A3;B:B)/ZÄHLENWENN(A:A;A3) von: edie
Geschrieben am: 08.01.2010 19:31:59

Hallo Worti,

ich habe den Fehler gefunden und so funktioniert es prima.

'=SUMMEWENN(A:A;A3;B:B)/ZÄHLENWENN(A:A;A3)

Vielen Dank.

Grüße


  

Betrifft: Worti ist n' Hammel von: WF
Geschrieben am: 08.01.2010 19:33:15

Hi,

die richtige Syntax von SUMMEWENN kennt er doch seit seiner Geburt:
=SUMMEWENN(A:A;A3;B:B)/ZÄHLENWENN(A:A;A3)

Salut WF


  

Betrifft: Mea Culpa und WF ist der Grösste von: Worti
Geschrieben am: 08.01.2010 20:11:38

Hallo Walter,
vielen Dank nochmal für deine Sylvester-Info, wie immer sehr lehrreich. Und das mit "WF ist der Grösste" stimmt ja nur teilweise, den an Masse schlag ich dich wohl um Längen, es sei den, du schleppst dich als Alter Herr nach einem Corps-Abend und etlichen"ad exercitium salamandri" mit 25 Litern Bier und anderem Gesöff intus in dein Bett.
Und selbstverständlich bin ich ein Depp, man soll ja auch nicht funktioniernde Formeln aus Excel kopieren und hinterher händisch dran rummfummeln.
Beim nächsten Excel-Treffen geht dein erstes Bier auf mich (Druck dir dass hier aus, damit du es mit deinen grade mal gut 18 Lenzen nicht vergisst.

Gruß Worti


  

Betrifft: Naja, "GROSS" ist relativ ;-)... von: NoNet
Geschrieben am: 08.01.2010 23:39:53

Hey Worti,

wie sang Mike Krüger einst : "♫ ♪ ...Walter war nicht groß, war eher klein.... ♫ ♪" ;-) - Bei Walter F. aus D. tippe ich da mal auf knapp 1,70 m - oder in Fuß (feet) : 5,5ft. :D

(Seine) wahre Größe zeigt sich erst bei wirklich komplexen Aufgabenstellungen oder auch anderen Anforderungen...

In diesem Sinne : Schönes WE,
NoNet


Beiträge aus den Excel-Beispielen zum Thema "Mittelwert nach Monaten berechnen"