Microsoft Excel

Herbers Excel/VBA-Archiv

max + datum?

Betrifft: max + datum? von: Niki
Geschrieben am: 15.02.2008 22:31:16

hallo Leute

fogendes Probelm:

Ich hätte gerne das aus einer liste aus Argumenten der größte ein eine Zelle kommt, bis da hin kann ichs auch noch. es soll aber auch das Datum in eine Zelle darunter, aus der betreffenden Zeile.

Vielen dank für eure Hilfe

Grüße
Niki

https://www.herber.de/bbs/user/49956.xls

  

Betrifft: AW: max + datum? von: Beate Schmitz
Geschrieben am: 15.02.2008 23:08:33

Hallo Niki,

 ABCDE
1Datumabcd
2beste"Wert""Wert""Wert""Wert"
3"Datum""Datum""Datum""Datum"
415.02.20073585
516.02.200763710
617.02.200757107
718.02.2007612118
819.02.20078959
918.02.2007 12  

Formeln der Tabelle
ZelleFormel
A9=WENN(B9<>"";INDEX(A:A;VERGLEICH(B9;B:B;0)); WENN(C9<>"";INDEX(A:A;VERGLEICH(C9;C:C;0)); WENN(D9<>"";INDEX(A:A;VERGLEICH(D9;D:D;0)); INDEX(A:A;VERGLEICH(E9;E:E;0)))))
B9=WENN(ZÄHLENWENN(B4:B8;MAX($B4:$E8)); MAX(B4:B8); "")
C9=WENN(ZÄHLENWENN(C4:C8;MAX($B4:$E8)); MAX(C4:C8); "")
D9=WENN(ZÄHLENWENN(D4:D8;MAX($B4:$E8)); MAX(D4:D8); "")
E9=WENN(ZÄHLENWENN(E4:E8;MAX($B4:$E8)); MAX(E4:E8); "")


Nicht befriedigend ist die Lösung, wenn in verschiedenen Zeilen gleich hohe max. Werte vorkommen.

Gruß,
Beate


  

Betrifft: Zu weit gesprungen? von: {Boris}
Geschrieben am: 15.02.2008 23:11:01

Liebe Beate,

ich glaube, es soll viel einfacher sein:

B2:
=MAX(B4:B8)

B3:
=INDEX($A4:$A8;VERGLEICH(B2;B4:B8;))

Formeln nach rechts kopieren.

Viele Grüße

Boris


  

Betrifft: AW: Zu weit gesprungen? von: Beate Schmitz
Geschrieben am: 15.02.2008 23:19:44

Ja, Boris,

das musssss besser werden!!!!


In diesem Sinne ein schönes Weekend und herzliche Grüße,
Beate


  

Betrifft: AW: max + datum? von: Jens
Geschrieben am: 15.02.2008 23:10:32

Hallo Niki

Schau mal hier:

http://www.excelformeln.de/formeln.html?welcher=24

Den größten Wert mit "max()" und die o.g. Formel dann für das Datum anwenden.

Gruß aus dem Sauerland

Jens


  

Betrifft: AW: max + datum? von: Daniel
Geschrieben am: 15.02.2008 23:11:26

HI

schreib mal dieser Formel in B2 (Grösster Wert)

=MAX(B4:B8)


und diese in B3 (Datum des Grössten Wertes)

=INDEX($A$4:$A$8;VERGLEICH(B2;B4:B8;0))



Gruß, Daniel


  

Betrifft: AW: max + datum? von: Niki
Geschrieben am: 15.02.2008 23:21:03

habs mit index ausprobiert und klappt prima
Also herzlichen danke an alle!!!


Grüsse Niki


  

Betrifft: AW: max + datum? von: Jens
Geschrieben am: 15.02.2008 23:27:24

Das hätte auch geklappt, wenn du es nicht ausprobiert hättest.


 

Beiträge aus den Excel-Beispielen zum Thema "max + datum?"