Microsoft Excel

Herbers Excel/VBA-Archiv

Herausforderung zur Summenbildung über SVERWEIS

Betrifft: Herausforderung zur Summenbildung über SVERWEIS von: Ferdinand
Geschrieben am: 22.06.2015 10:37:25

Hallo zusammen,

ich habe eine Herausforderung zu lösen...

Über SVERWEIS möchte ich in einer Matrix einen passenden Wert suchen.
Danach möchte ich den gefundenen Zellwert mit weiteren Werte addieren.
Die Endzelle meiner Summenformel möchte ich definieren, in dem ich die ADRESSE des über den SVERWEIS gefundenen Zelle als Anfangszelle (von) und eine absolute Zahl dazu addiert als die Endzelle (bis) definieren möchte.

Ungefähr so:

=SUMME
(
(ADRESSE
(SVERWEIS(A5;[MATRIX];2;FALSCH)
)
:
(VERKETTEN
(SPALTE
(SVERWEIS(A5;[MATRIX];2;FALSCH)
)
;
(ZEILE
(SVERWEIS(A5;[MATRIX];2;FALSCH +[absolute Zahl])
)
)
)

  

Betrifft: AW: Herausforderung zur Summenbildung über SVERWEIS von: Jack_d
Geschrieben am: 22.06.2015 10:47:24

Moin Moin

meinst du sowas?


Grüße


Tabelle1

 ABCDEFG
1Hans2     
2Peter3     
3Joachim 1     
4Axel 3     
5Norbert4     
6Else5     
7Nora12  Von Hans 
8    bisElse 
9    Summe18 
10       

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
F9=SUMME(INDEX(B1:B7;VERGLEICH(F7;A1:A7;0)):INDEX(B1:B7;VERGLEICH(F8;A1:A7;0)))  =SUM(INDEX(R[-8]C[-4]:R[-2]C[-4],MATCH(R[-2]C,R[-8]C[-5]:R[-2]C[-5],0)):INDEX(R[-8]C[-4]:R[-2]C[-4],MATCH(R[-1]C,R[-8]C[-5]:R[-2]C[-5],0)))

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.15 einschl 64 Bit



  

Betrifft: AW: Herausforderung zur Summenbild. über SVERWEIS von: Ferdinand
Geschrieben am: 22.06.2015 11:01:53

Hallo Jack_d,

ich habe einmal einen Beispielsdatei erstellt und lade diese hoch.

Gruß Ferdinand

https://www.herber.de/bbs/user/98370.xlsx


  

Betrifft: AW: Herausforderung zur Summenbild. über SVERWEIS von: Daniel
Geschrieben am: 22.06.2015 11:32:30

Hi

für dein Beispiel würde ich das so lösen, dh mit INDEX, und die Zeilennummer berechnest du direkt aus Jahr und Monat.
SVerweis bzw Vergleich hätte hier den Nachteil, dass du nur nach dem erste Mai in 2015 suchen kannst, aber nicht nach dem zweiten von 2016.

=SUMME(INDEX(B5:B53;(JAHR($E$1)-2015)*12+MONAT($E$1);1):INDEX(B5:B52;(JAHR($E$2)-2015)*12+MONAT($E$2) )) 
Gruß Daniel


  

Betrifft: AW: Herausforderung zur Summenbild. über SVERWEIS von: Ferdinand
Geschrieben am: 22.06.2015 12:12:19

Hallo Daniel,

vielen Dank, das ist die Lösung!!!
... und ich glaube, ich habe es sogar verstanden...

Gruß

Ferdinand


 

Beiträge aus den Excel-Beispielen zum Thema "Herausforderung zur Summenbildung über SVERWEIS"