Microsoft Excel

Herbers Excel/VBA-Archiv

Wie(so) kann man Suchkriterien in Excel (nicht)...

Betrifft: Wie(so) kann man Suchkriterien in Excel (nicht)... von: coalminestepper
Geschrieben am: 17.08.2004 16:31:43

.... verknüpfen?

Bsp bei den Funktionen:

ZÄHLENWENN: geht meiner ansicht nach nur so ZÄHLENWENN(xc:xc;>5)-ZÄHLENWENN(xc:xc;<7). wieso nicht mit einer zählenwenn anweisung?????

oder

SUMMEWENN: hier hab ich keiner Ahnung, bitte um response :o)

SUMMEWENN($E$2:$E$723;"<5";($C$2:$C$723))-SUMMEWENN($E$2:$E$723;">7";($C$2:$C$723)) ???

danke.

  


Betrifft: AW: Wie(so) kann man Suchkriterien in Excel (nicht)... von: ransi
Geschrieben am: 17.08.2004 17:04:51

hallo


=ZÄHLENWENN(xc:xc;">5")-ZÄHLENWENN(xc:xc;"<7") funktioniert.
Was soll das "Zählenwenn()" oder "summewenn()" denn berechnen?

Ransi


  


Betrifft: Beste Funktion abhängig von Anzahl Suchkriterien von: Beate Schmitz
Geschrieben am: 17.08.2004 23:11:48

Hallo Coalminestepper,

SUMMEWENN und ZÄHLENWENN berücksichtigen jeweils nur eine Bedingung. Außer du verbindest sie irgendwie, so wie in deinem Beispiel.

Willst du mehr Kriterien berücksichtigen, steht die Funktion SUMMENPRODUKT zur Verfügung, sowohl für Summe als auch für Anzahl. Du findest dazu in der Hilfe Einiges und viele Threads, wenn du hier in der Recherche danach suchst.

Ansonsten bitte gezielter nachfragen, was du genau möchtest.

Gruß,
Beate