Herbers Excel-Forum - das Archiv

ZÄHLENWENN bei zwei übereinstimmenden Kriterien

Bild

Betrifft: ZÄHLENWENN bei zwei übereinstimmenden Kriterien
von: Andreas.R

Geschrieben am: 07.04.2005 10:59:20
Hallo Excelfreunde
ich wurde Heute schon mal geholfen
nur habe ich jetzt ein anderes Problem
ich habe in Spalte "A" ein berechnetes Alter stehen (zB.19 oder 24 oder 40 usw.)
in Spalte "B" habe ich Zeichenfolgen stehen (zB.321a oder 321b oder 321c usw.)
Jetzt trage ich in Zelle "C1" das Alter zB."19" ein, und in Zelle "C2" die Zeichenfolgen zB."321a" ein.
Jetzt soll mir in Zelle "D1" die Anzahl der gefundenen Zeilen die dem Auswahlkriterium Alter (Zelle"C1")und Auswahlkriterium Zeichenfolge (Zelle"C2")
entsprechen.
Also wenn in Zelle "C1" 19 steht, und in Zelle "C2" 321a steht,
soll die Spalte "A" nach der Zahl 19 gesucht werden und nur die Anzahl gezählt werden, wenn in Spalte "B" daneben 321a steht
ich kriege die Formel allein einfach nicht gebacken
vielen Dank nochmals für alle die mir bei meinem Problem helfen können.
Gruß Andreas.R

Bild

Betrifft: AW: ZÄHLENWENN bei zwei übereinstimmenden Kriterien
von: Marcus Rose
Geschrieben am: 07.04.2005 11:10:44
Hallo,
das kannst Du z.B. so:
=SUMMENPRODUKT((A5:A8=C1)*(B5:B8=C2))
Gruß
Marcus
http://xltreff.de
Bild

Betrifft: AW: ZÄHLENWENN bei zwei übereinstimmenden Kriterien
von: Peter Niemeyer

Geschrieben am: 07.04.2005 11:17:01
Hallo !
Das geht am schnellsten mit der Summenprodukt-Formel. In Deinen Beispiel aktuell mit:
=SUMMENPRODUKT((A1:A10=C1)*(B1:B10=C2))
Damit kannst Du auch beliebig weitere Abfragen definieren, einfach eine neue Abfrage in eine weitere Klammer mit "*" setzen. Wenn Du nun noch Werte summieren willst (zum Beispiel Werte zu den einzelnen Personen hast) packst Du die mit rein, z.b. (E1:E10), also ohne "=" irgendwas. Ich hoffe, ich habe mich halbwegs klar ausgedrueckt :-)
Schoene Gruesse,
Peter
Bild

Betrifft: AW: ZÄHLENWENN bei zwei übereinstimmenden Kriterien
von: Andreas.R
Geschrieben am: 07.04.2005 11:52:33
Hallo Marcus und Peter
superschnelle Antwort und genau das was ich wollte
Danke nochmals und einen schönen Tag noch
Gruß Andreas
 Bild
Excel-Beispiele zum Thema "ZÄHLENWENN bei zwei übereinstimmenden Kriterien"
Zellenwert als Autofilter-Kriterienwert Werte nach zwei Kriterien auswählen
Datensätze nach zwei Kriterien in neues Blatt übernehmen Tabelle nach mehreren Kriterien summieren
Tabellenwerte nach Kriterien auf Arbeitsblätter verteilen Anzahl nach 2 Kriterien ermitteln mit DB-Funktion und MatrixFormel
Autofilter-Kriterien über UserForm vorgeben Datumsbereich in Abhängigkeit von 3 Kriterien markieren
Werte nach Kriterien prüfen und auf Blätter verteilen SVERWEIS unter Verwendung mehrer Kriterien