Wenn-Formel mit Variable...

Bild

Betrifft: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 18.04.2005 13:55:56
Hi
Also, ich brauch ne Formel... Es soll 1 angezeigt werden wenn in Zelle B3 irgendwas mit KD steht. Wieso geht das nicht, wie ich es habe?
=WENN(B3="*KD*";"1";"2")
Danke
JayLen

Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: Hajo_Zi
Geschrieben am: 18.04.2005 14:00:02
Hallo JayLen
=WENN(ISTFEHLER(FINDEN("KD";B4));2;1)
Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.



"Wer Rechtschreibfehler findet, darf sie behalten!"
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 18.04.2005 14:32:22
Hi, OK danke das haut hin.
Und jetzt noch eine Frage:
Geht das auch mit einer 6 Stelligen Zahl die mit 1 anfängt? Also statt KD!
Wie muss das aussehen?
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: Galenzo
Geschrieben am: 18.04.2005 14:54:39
die Bedingung lautet:
GANZZAHL(E19/100000)=1 ???
Viel Erfolg!
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 18.04.2005 15:38:48
Hi
Also so gehts net. Das Ding ist ja, dass in der Zelle, in der die 6 stellige Zahl steht auch noch Text sein kann. Also im logischen aber falschen Sinne:
=WENN(ISTFEHLER(FINDEN("1XXXXX";H3));"";"/")
Noch wer ne Idee?
ciao JayLen
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: heikoS
Geschrieben am: 18.04.2005 15:44:04
Hallo JayLen,
wenn Du nur die 1 abfragen willst: =WENN(LINKS(H3;1)="1";"/";"")
wenn du die 1 und die Länge abfragen willst: =WENN(UND(LÄNGE(H3)=6;LINKS(H3;1)="1");"/";"")
Klappt´s so?

Gruß Heiko
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 18.04.2005 15:56:39
hmm, nee, des funzt auch net. Es würde wahrscheinlich funktionieren, wenn da kein Text mit drin steht. Also bei H3 steht in meinem Fall drin: KDNR. 142011...! Und dann soll er den Slash machen...
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 18.04.2005 16:00:22
Was ich dazu gerade noch sagen muss ist, dass in H3 auch 1 vorkommen kann, was nichts mit der Sache zu tun hat. Das heißt, dass es schon 6 stellig sein muss.
Bild

Betrifft: AW: das geht so...
von: FP
Geschrieben am: 18.04.2005 22:54:13
Hallo JayLen,
Bedingung: 1 Leerstelle muss vor der "1" vorhanden sein und die Zahl muss aus 6 Ziffern bestehen, beginnend mit 1
=WENN(ISTZAHL(LINKS(ERSETZEN(H3;1;SUCHEN(" 1";H3);"");6)+0);"\";"")
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: AW: das geht so...
von: JayLen
Geschrieben am: 19.04.2005 10:03:51
Servus
Also meine Formel sieht jetzt so aus...:
=WENN(UND(B3>99999;B3<200000);"/";WENN(ISTZAHL(LINKS(ERSETZEN(B3;1;SUCHEN("1?????";B3);"");6)+0);"/";""))
Er fängt alle Beispiele ab. Wenn die Zahl 5 stellig ist auch, aber leider nicht, wenn die Zahl mehr als 6 Stellen hat.
Beispiele:-----------Ergebnis--------------Soll-Ergebnis
12345----------------0---------------------0
Text 12345----------0---------------------0
123456---------------/---------------------/
123456 Text---------/---------------------/
Text 123456---------/---------------------/
Text 123456 Text---/---------------------/
1234567--------------/---------------------0
1234567 Text--------/---------------------0
Hat jemand noch eine Idee, wie ich diese letzten auch noch abfangen kann?
Danke und ciao
JayLen
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: HermannZ
Geschrieben am: 18.04.2005 15:50:43
Hallo ciao JayLen,
meinst du das so???
Beispiel;
VersuchA
 ABC
3   
4 ges. Zeichen 
5ADB123456GHJ11
6ADB923456GHJ 2
7   
Formeln der Tabelle
C5 : =WENN(ISTFEHLER(WENN(FINDEN($B$5;A5);1;2));2;1)
C6 : =WENN(ISTFEHLER(WENN(FINDEN($B$5;A6);1;2));2;1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

unterscheidet auch gross und kleinschreibung
Gruß Hermann
Bild

Betrifft: AW: =2-ZÄHLENWENN(B4;"*KD*") o.T.
von: FP
Geschrieben am: 18.04.2005 22:30:59

Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 18.04.2005 16:03:57
Nee, Ich GLAUBE mal nicht, dass es das ist was ich suche... Sorry
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: Hajo_Zi
Geschrieben am: 18.04.2005 18:28:19
Hallo JayLen,
ein Hallo zu Beginn und ein Gruß am Ende läst den Beitrag doch gleich viel freundlicher aussehen. Auch wenn Du den Beitrag am Computer eingibst sitzen an der anderen Seite doch Leute und keine Maschinen die Deine Frage beantworten und da sollte Zeit für die paar Worte doch vorhanden sein.
Wenn ich es richtig sehe liefern alle Vorschlage das von Dir im ersten Beitrag angesprochene Ergebnis. Du muß schon ein wenig klarer werden, was falsch ist.
Gruß Hajo
Das Forum lebt auch von den Rückmeldungen.

"Wer Rechtschreibfehler findet, darf sie behalten!"
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 18.04.2005 21:38:35
Hi
Sorry, das ich mich da bisschen falsch verhalten habe. Ist normalerweise auch nicht meine Art das ganze nicht mit Hallo und Danke zu umschmücken. In diesem Thread spricht aber auch garnichts für mich; ich habe ja bei näherer Betrachtung so gut wie garnicht mal Danke gesagt. Ich bitte das zu entschuldigen und danke dir, dass du mich darauf aufmerksam gemacht hast. Das war mir garnicht bewusst. Ich danke natürlich allen Leuten, die mir weiterhelfen und bin mir auch durchaus bewusst, dass es keine Maschinenen. Das habe ich wohl nicht genug kenntlich gemacht...Sorry...
Zum Problem:
Das funktioniert so:
=WENN(UND(LÄNGE(H3)=6;LINKS(H3;1)="1");"/";"")
Allerdings nur, wenn die Zelle H3 eine 6 stellige Zahl hat die mit 1 beginnt.
Es kann aber auch der Fall sein, dass in der Zelle steht: Text 123456
Und da funktioniet die Formel dann nicht. Ich dachte, es auch so formuliert zu haben.
Also nochmals Danke an alle die hier im Forum für schnelle Antworten sorgen.
ciao JayLen
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: HermannZ
Geschrieben am: 19.04.2005 10:41:50
Hallo JayLen,
noch ein Beispiel;
hier wird in der Zelle gprüft ob die Zahl sechstellig ist und mit eins beginnt,wenn ja wird / gesetzt sonst leer.
Beispiel;
Text
 ABC
914   
915ARTIKEL12345  
916ARTIKEL1234578  
917ARTIKEL123456 /
918ARTIKEL123457923  
919AB Artikel 123456 /
920  Formel nach unten
921  kopieren
Formeln der Tabelle
C915 : {=WENN((LÄNGE(TEIL(LINKS(A915;MAX(ISTZAHL(TEIL(A915;SPALTE(1:1);1)*1)*SPALTE(1:1)));MIN(WENN(ISTZAHL(TEIL(A915;SPALTE(1:1);1)*1);SPALTE(1:1)));55)*1)=6)*(LINKS(TEIL(LINKS(A915;MAX(ISTZAHL(TEIL(A915;SPALTE(1:1);1)*1)*SPALTE(1:1)));MIN(WENN(ISTZAHL(TEIL(A915;SPALTE(1:1);1)*1);SPALTE(1:1)));55)*1;1)="1")*1=0;"";"/")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Ich hoffe das ich das jetzt richtig verstanden habe.
Gruß hermann
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 19.04.2005 10:55:21
Hi
Interessant wäre mal, was du für ein Office hast!?! Ich bekomme mit XP einen #Wert Fehler... hmm?
ciao JayLen
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: HermannZ
Geschrieben am: 19.04.2005 11:04:18
Hallo JayLen,
deine Feststellung hat nichts mit der Office Version zu tun,sondern du must auch die Antwort richtig und vollständig, hier liegt die Betonung auf vollständig, lesen.
Unten steht;
Umrandete Klammer {} nicht mit eingeben
sondern Formel mit Strg-Shift-Return abschliessen.
denn ohne dies erhällst du natürlich den Fehlerwert.
PS: Ich nutze die gleiche Version...
Gruß Hermann
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 19.04.2005 11:51:01
Servus
Ich habe das durchaus gelesen.
Ich gleiche die Formel der Zelle an und füge sie so ein:
=WENN((LÄNGE(TEIL(LINKS(B3;MAX(ISTZAHL(TEIL(B3;SPALTE(1:1);1)*1)*SPALTE(1:1)));MIN(WENN(ISTZAHL(TEIL(B3;SPALTE(1:1);1)*1);SPALTE(1:1)));55)*1)=6)*(LINKS(TEIL(LINKS(B3;MAX(ISTZAHL(TEIL(B3;SPALTE(1:1);1)*1)*SPALTE(1:1)));MIN(WENN(ISTZAHL(TEIL(B3;SPALTE(1:1);1)*1);SPALTE(1:1)));55)*1;1)="1")*1=0;"";"/")
Also von daher habe ich, soweit ich das jetzt beurteilen kann, alles richtig gemacht!!
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: HermannZ
Geschrieben am: 19.04.2005 12:39:36
Hallo JayLen,
ich kann das nicht nachvollziehen,ich habe die Formel so wie du sie jetzt gepostet
hast einfach kopiert und es geht auch.
siehe Beispiel;
VersuchA
 BC
2  
3ADF123456hgt/
4ADF12345689hgt 
5ADF12345 
6ADF 123456/
7  
Formeln der Tabelle
C3 : {=WENN((LÄNGE(TEIL(LINKS(B3;MAX(ISTZAHL(TEIL(B3;SPALTE(1:1);1)*1)*SPALTE(1:1)));MIN(WENN(ISTZAHL(TEIL(B3;SPALTE(1:1);1)*1);SPALTE(1:1)));55)*1)=6)*(LINKS(TEIL(LINKS(B3;MAX(ISTZAHL(TEIL(B3;SPALTE(1:1);1)*1)*SPALTE(1:1)));MIN(WENN(ISTZAHL(TEIL(B3;SPALTE(1:1);1)*1);SPALTE(1:1)));55)*1;1)="1")*1=0;"";"/")}
C4 : {=WENN((LÄNGE(TEIL(LINKS(B4;MAX(ISTZAHL(TEIL(B4;SPALTE(2:2);1)*1)*SPALTE(2:2)));MIN(WENN(ISTZAHL(TEIL(B4;SPALTE(2:2);1)*1);SPALTE(2:2)));55)*1)=6)*(LINKS(TEIL(LINKS(B4;MAX(ISTZAHL(TEIL(B4;SPALTE(2:2);1)*1)*SPALTE(2:2)));MIN(WENN(ISTZAHL(TEIL(B4;SPALTE(2:2);1)*1);SPALTE(2:2)));55)*1;1)="1")*1=0;"";"/")}
C5 : {=WENN((LÄNGE(TEIL(LINKS(B5;MAX(ISTZAHL(TEIL(B5;SPALTE(3:3);1)*1)*SPALTE(3:3)));MIN(WENN(ISTZAHL(TEIL(B5;SPALTE(3:3);1)*1);SPALTE(3:3)));55)*1)=6)*(LINKS(TEIL(LINKS(B5;MAX(ISTZAHL(TEIL(B5;SPALTE(3:3);1)*1)*SPALTE(3:3)));MIN(WENN(ISTZAHL(TEIL(B5;SPALTE(3:3);1)*1);SPALTE(3:3)));55)*1;1)="1")*1=0;"";"/")}
C6 : {=WENN((LÄNGE(TEIL(LINKS(B6;MAX(ISTZAHL(TEIL(B6;SPALTE(4:4);1)*1)*SPALTE(4:4)));MIN(WENN(ISTZAHL(TEIL(B6;SPALTE(4:4);1)*1);SPALTE(4:4)));55)*1)=6)*(LINKS(TEIL(LINKS(B6;MAX(ISTZAHL(TEIL(B6;SPALTE(4:4);1)*1)*SPALTE(4:4)));MIN(WENN(ISTZAHL(TEIL(B6;SPALTE(4:4);1)*1);SPALTE(4:4)));55)*1;1)="1")*1=0;"";"/")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hermann
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 20.04.2005 10:21:11
Servus
Habe nochmal alles geprüft. Ich füge es definitiv so ein, wie ich es auch geschrieben habe. Daher auch mein Gedanke, dass es evtl an der Office Version liegt. Ich weiß leider auch nicht was da schief läuft! Trotzdem danke für deie Bemühungen!
Hat jemand noch eine Idee bezüglich des Problems?
Gruss
JayLen
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: HermannZ
Geschrieben am: 20.04.2005 16:59:54
Hallo JayLen,
dann bleibt nur noch das du die Datei oder zumindest einen Ausschnitt mit dem Fehler einmal hochladest,dann werden wir ja sehen was Sache ist.
Gruß hermann
Bild

Betrifft: AW: Wenn-Formel mit Variable...
von: JayLen
Geschrieben am: 22.04.2005 14:46:33
Servus
Hier mal eine Datei, wo ich es schlichtweg so eingefügt habe, wie das geschrieben hast.
Schau mal wie es bei dir aussieht!?! Bei mir sind in C3-C6 #Wert Fehler.
https://www.herber.de/bbs/user/21561.xls
Ciao und Danke
JayLen
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wenn-Formel mit Variable..."