Summenformel + Offset

Bild

Betrifft: Summenformel + Offset
von: HeinzS
Geschrieben am: 08.06.2015 10:31:34

Hallo, ich habe folgende Herausforderung. Abhängig von einer Startwoche (die pro Zeile unterschiedlich ist)sollen alle getätigten Umsätze einer bestimmten Periode summiert werden. Beispiel: Startwoche ist 201501 (erhalte ich leider als Zahl)somit sollen die Umsätze des Zeitraums 201501 bis inkl. 201513 aufsummiert werden. Die Umsätze stehen in den Spalten.
Ich vermute hier eine Kombination mittels "Index(Match)" Funktion um die Startwoche festzulegen und einer "OFFSET" Funktion, um den Bereich zu definieren.
Will mir aber nicht wirklich gelingen.
Kann mir wer hier bitte helfen. 'Ach ja hab die englische Version.
https://www.herber.de/bbs/user/98075.xlsx
Danke Heinz

Bild

Betrifft: AW: Summenformel + Offset
von: SF
Geschrieben am: 08.06.2015 10:37:52
Hola,
warum wird nur Zeile 2 beachtet und nicht auch z.B. Zeile 4, 5, 7, 8? Dort steht als Startwoche auch 201501 drin.
Gruß,
steve1da

Bild

Betrifft: AW: Summenformel + Offset
von: HeinzS
Geschrieben am: 08.06.2015 11:18:30
Steve, der Grund ist, daß es sich um andere Positionen handelt und somit seperat dargestellt werden müssen.

Bild

Betrifft: AW: Summenformel + Offset
von: SF
Geschrieben am: 08.06.2015 10:40:34
Hola,
in W2:
=SUMMENPRODUKT(($C$1:$V$1>=201501)*($C$1:$V$1<=201513)*(C2:V2))
Gruß,
steve1da

Bild

Betrifft: AW: Summenformel + Offset
von: UweD
Geschrieben am: 08.06.2015 10:47:37
Hallo
so ...

=SUMMENPRODUKT(($C$1:$V$1*1>=$B2)*($C$1:$V$1*1<=$B2+12)*($C2:$V2))

In Zeile 6 stimmt dein Beispiel nicht...
Gruß UweD

Bild

Betrifft: AW: Summenformel + Offset
von: SF
Geschrieben am: 08.06.2015 10:50:25
Hola,
hast Recht. Dann müssen Startwoche und Zeitraum in Zellen eingetragen werden und die Formel muss dann darauf verweisen.
Gruß,
steve1da

Bild

Betrifft: AW: Summenformel + Offset
von: UweD
Geschrieben am: 08.06.2015 10:58:22
Hallo Nochmal
Wenn Spalte B und Zeile 1 die gleiche Formatierung (Zahlen) haben dann auch so...

=SUMMEWENNS($C2:$V2;$C$1:$V$1;">="&$B2;$C$1:$V$1;"<="&$B2+12)

Formeln nach unten kopieren

Gruß UweD

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summenformel + Offset"