nochmals Summenformel

Bild

Betrifft: nochmals Summenformel
von: mike49
Geschrieben am: 03.06.2015 20:07:22

Hallo Leute,
ich melde mich nochmals wegen meiner Summenformel, die noch nicht so funktioniert, wie ich es gerne hätte.
In meinem Arbeitsblatt gebe ich im Bereich B5:B35 den Arbeisbeginn am Vormittag und in C5:C35 die Endzeit ein. Ebenso Im Bereich D5:D35 den Arbeitsbeginn bzw. E5:E35 die Endzeit für den Nachmittag ein. In F5:F35 wird automatisch eine etwaige Pausenzeit eingetragen.
Die Summenformel für die Zeile 5 z.B lautet: =WENN(B5="Urlaub";ZEITWERT("1:58");WENN(B5="Krank";ZEITWERT("1:58");WENN(B5<=C5;C5-B5;B5+C5*1) +WENN(D5<=E5;E5-D5;D5+E5*1)-F5)). Das funktioniert auch.
Nun das was mich stört:
Gebe ich z.B. in B5 die Anfangszeit "9:00" ein, wird sofort diese Zeit als Summe in H5 angezeigt. Genauso verhält es sich, wenn ich z.B. "14:00" als Anfangszeit für den Nachmittag eintrage. Die Summenzeit sollte aber immer erst angezeigt werden, wenn auch die jeweils dazugehörige Endzeit eingetragen wurde, quasi als Differenzwert von Anfang- und Endwert.
Kann man o.g. Summenformel entsprechend ändern?
Wäre für eine Hilfe dankbar.
Gruß
mike49

Bild

Betrifft: benutze für die SummenFormel --> UND ... owT
von: Matthias L
Geschrieben am: 03.06.2015 20:16:18


Bild

Betrifft: AW: nochmals Summenformel
von: Spenski
Geschrieben am: 03.06.2015 20:45:40
Hallo mike
mit Zeitwert("1:58") hab ich nicht ganz verstanden, soll aber nicht so wild sein.
In deiner Formel sind noch einige andere Fehler zb :
WENN(B5<=C5;C5-B5;B5+C5*1)
wenn B5 grösser als C5 ist sollen die beiden werte addiert werden? heisst wenn ich mich von 9Uhr bis 3Uhr einschreibe habe ich 12 stunden gearbeitet.
versuch mal diese formel:
=WENN(ODER(B5="krank";B5="Urlaub");ZEITWERT("1:58");WENN(UND(B5<>"";C5<>"";C5>B5); C5-B5)+WENN(UND(D5<>"";E5<>"";E5>D5);E5-D5))
hoffe das passt, wenn nicht sag bescheid
gruß
christian

Bild

Betrifft: AW: nochmals Summenformel
von: Spenski
Geschrieben am: 03.06.2015 20:57:12
natürlich kannst du die Fehleingaben auch noch abfangen und dir einen Fehler anzeigen lassen.
zb vormittags ist ´"von" grösser als "bis" ...oder vormittags "bis" ist grösser als nachmittags "von"
=WENN(ODER(B5>C5;D5>E5;UND(B5="";C5<>0);UND(D5="";E5<>0);D5<C5);"FEHLEINGABE"; WENN(ODER(B5="krank";B5="Urlaub");ZEITWERT("1:58");WENN(UND(B5<>"";C5<>"";C5>B5); C5-B5)+WENN(UND(D5<>"";E5<>"";E5>D5);E5-D5)))

Bild

Betrifft: AW: nochmals Summenformel
von: mike49
Geschrieben am: 03.06.2015 21:39:41
Hallo Christian,
das klappt prima. Genau wie ich es wollte. Danke für deine Hilfe.
Ich hätte da noch was mit der "Bedingten Formatierung". Vielleicht kennst du dich ja damit aus und kannst mir helfen?
Für die Samstage habe ich folgende Regel:=WOCHENTAG($A5;1)=7 für den Bereich $A$5:$J$35 mit entsprechender Schrift- und Füllfarbe.
Für die Feiertage diese:=ISTZAHL(SVERWEIS($A5;Feiertage;1;0)) für den selben Bereich.
Fällt nun ein Feiertag auf einen Samstag, wird die Formatierung des Samstags gewählt und nicht wie ich will die des Feiertags (Schrift- und Füllfarbe).
Kann man das ändern?
Gruß
mike49

Bild

Betrifft: AW: nochmals Summenformel
von: Spenski
Geschrieben am: 03.06.2015 21:46:07
Puuh mit bedingter Formatierung kannst du mich jagen :)
Klingt aber nach der Reihenfolge deiner bedingten Formatierungen.
Wenn du dir alle Formatierungen im Blatt aufrufst hast du da ja ne Liste.... Änder einfach mal die Reihenfolge der beiden Formatierungen
Gruss

Bild

Betrifft: AW: nochmals Summenformel
von: mike49
Geschrieben am: 03.06.2015 22:39:28
Super. Das klappt mit der Reihenfolge.
Danke für den Tipp.
Gruß
mike49

 Bild

Beiträge aus den Excel-Beispielen zum Thema "nochmals Summenformel"