Microsoft Excel

Herbers Excel/VBA-Archiv

Dynamische Summenformel


Betrifft: Dynamische Summenformel von: Schmiddi
Geschrieben am: 03.08.2018 10:47:15

Hallo Excel Spezialisten,

Ich benötige dringend Hilfe bei einer Excelherausforderung die ich mich auf meiner Arbeit stellen muss und hoffe dabei euf euer Wissen.

Der Aufbau meiner Spalte L sieht wie folgt aus:
L1="Summe", L2="2";L3="2"; L4="Summe"; L5= "2"; L6="2"; L7="Summe" L8="2" L9="Summe" usw.

D.h. nach jedem Wert "Summe" folgt unterhalb entweder 2x oder 1x die "2".
Nun benötige ich ein Makro (damit kenne ich mich leider nicht aus) oder eine Formel, mit dem der Wert "Summe" mit einer Summenformel ersetzt wird und die darunterliegenden "2"-Werte summiert.

z.B. für L1 = Summe(L2:L3) für L4= Summe(L5:L6) und für L7 = Summe(L8) usw.

Ich hoffe meine Ausführung war soweit verständlich und wäre unendlich dankbar, wenn mir jemand bei dieser Angelegenheit helfen könnte.

  

Betrifft: AW: Dynamische Summenformel von: Bernd
Geschrieben am: 03.08.2018 10:52:38

Hi,

stelle mal eine Beispieldatei hier hoch, wo Ausgangs- und gewünschte Endsituation dargestellt sind!

MfG Bernd


  

Betrifft: AW: Dynamische Summenformel von: Schmiddi
Geschrieben am: 03.08.2018 11:19:02

Hallo Bernd,
Danke für deine Antwort.
Ich habe eine Beispieldatei hochgeladen:
https://www.herber.de/bbs/user/123100.xlsx

Ausgangssituation ist in Spalte A zu erkennen.
Setzt man dort einen Filter und blendet alle leeren Zellen aus, ist das Ergebnis Spalte C und somit mein beschriebenes "Problem".
In Spalte E habe ich bis Zeile 23 begonnen, wie es idealerweise aussehen sollte.

Es sollte "dynamisch" sein, da die Anzahl der "2"-Werte zwar immer 1x oder 2x ist aber immer variiert.

Ich hoffe es war soweit verständlich :)


  

Betrifft: AW: Dynamische Summenformel von: ludicla
Geschrieben am: 03.08.2018 10:54:07

Hallo Schmiddi

Du brauchst doch nur die ersten drei Zeilen füllen,
in der ersten die Summe der 2.und 3. und dann einfach runterkopieren.

Gruss Ludicla


  

Betrifft: AW: als reine Formellösung mit zwei Formeln ... von: neopa C
Geschrieben am: 03.08.2018 20:12:25

Hallo Schmiddi,

... und zwar eine Formel in einer Hilfsspalte zu Deiner Liste Tabelle2. Schreibe in B1 z.B. "HS" und in B2 folgende Formel:

=WAHL(([@Ausgangssituation]="")+ISTZAHL([@Ausgangssituation])*2+ ([@Ausgangssituation]="Summe")*3;"";
[@Ausgangssituation];SUMME([@Ausgangssituation]:INDEX([Ausgangssituation];
WENNFEHLER(ZEILE([@Ausgangssituation])-1+VERGLEICH("Summe";A3:INDEX([Ausgangssituation];
AGGREGAT(14;6;ZEILE([Ausgangssituation])-1;1));0);AGGREGAT(14;6;ZEILE([Ausgangssituation])-1;1)))))


Die Spalte B kannst Du dann einfach ausblenden. Dein gesuchtes Ergebnis ermittelst Du, in dem Du in E2:

=WENNFEHLER(INDEX(Tabelle2[HS];AGGREGAT(15;6;(ZEILE(Tabelle2[Ausgangssituation])-1)
/(Tabelle2[Ausgangssituation]<>"");ZEILE(A1)));"")


einschreibst und diese weit genug ziehend nach unten kopierst.

Gruß Werner
.. , - ...


  

Betrifft: Crossposting von: SF
Geschrieben am: 03.08.2018 20:29:53

http://www.vba-forum.de/forum/View.aspx?ziel=46170-Dynamischer_Summenbereich


Beiträge aus dem Excel-Forum zum Thema "Dynamische Summenformel"