Live-Forum - Die aktuellen Beiträge
Datum
Titel
19.07.2024 18:36:17
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

letzten Eintrag aus 3 Spalten Summenformel?

letzten Eintrag aus 3 Spalten Summenformel?
07.03.2018 09:13:59
Lisa
Hallo zusammen, ich benötige bitte einmal Eure Hilfe.
Ich habe eine Tabelle mit 3 Spalten.
Erste Spalte Material
Zweite Gültig ab
Dritte Spalte Gewicht
In der ersten Spalte können die Artikel mehrfach vorkommen.
Zu diesen Artikeln gibt es eine unbestimmte Anzahl an Einträgen (Zeilen)
In der zweiten Spalte Gültigkeitsdatum gibt es dazu mehrere Einträge mit einem entsprechendem Gewicht in der dritten Spalte.
Ich benötige in einer vierten Spalte das Gewicht aus immer dem letzter gültiger Eintrag zur Materialnummer und dem letzten gültigen Datum.
Im Anhang ist es evtl besser zu erkennen was gemeint ist.
Wenn ihr hierzu eine Idee habt, würde ich mich sehr über Eure Hilfe freuen.
Liebe Grüße Lisa
https://www.herber.de/bbs/user/120249.xls

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: letzten Eintrag aus 3 Spalten Summenformel?
07.03.2018 09:17:28
SF
Hola,
=WENN(B2=MAX(WENN($A$2:$A$14=A2;$B$2:$B$14));C2;"")

die Formel mit Strg-Shift-Enter abschließen.
Gruß,
steve1da
AW: letzten Eintrag aus 3 Spalten Summenformel?
07.03.2018 09:31:21
Lisa
WOW, recht herzlichen Dank.
Das ging wahnsinnig schnell. vielen dank funktioniert perfekt.:)
Liebe Grüße Lisa
AW: letzten Eintrag aus 3 Spalten Summenformel?
07.03.2018 09:23:15
Hajo_Zi
Hallo Lisa,

Tabelle1
 E
1letzter gültiger Eintrag
221,6
3 
4 
5 
6 
721,4
8 
9 
1021,6
11 
12 
13 
14 

verwendete Formeln
Zelle Formel Bereich N/A
E2:E14{=WENN(A1<>A2;INDEX($C$2:$C$14;MAX(($A$2:$A$14=A2)*ZEILE($A$2:$A$14))-1);"")}$E$2 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit



Beiträge von Werner, Luc, robert, J.O.Maximo und folgende lese ich nicht.
Anzeige
AW: letzten Eintrag aus 3 Spalten Summenformel?
07.03.2018 09:34:14
Lisa
vielen Dank, ich habe die Formel von steve1da verwendet diese funktioniert perfekt.
Mit dieser erhalte ich keine Ergebnisse.?
AW: letzten Eintrag aus 3 Spalten Summenformel?
07.03.2018 09:41:42
Hajo_Zi
man sollte den Beitrag schon komplett lesen. In meiner Datei geht es wie Du aus meinem Beitrag siehst.
nur wenige schauen auf Deinen Rechner und sehen die Datei.
Ich möchte gerne den Fehler im Original sehen.
Ich baue keine Datei nach. Die Zeit hat schon jemand investiert.
Ein Nachbau sieht meist anders aus als das Original. Darum sollte das Original verlinkt werden.
Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten anonymisieren bzw. pseudonymisieren.
Gruß Hajo
Anzeige

302 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige