Nur sichtbare Zellen addieren

Bild

Betrifft: Nur sichtbare Zellen addieren
von: Egon
Geschrieben am: 17.11.2003 08:46:17

Hallo,

Gibt es eine Möglichkeit formelmäßig nur eingeblendete Zellen zu erfassen?
So wie Teilergebnis?

Viele Grüße an die fleißigen Antworter

Egon

Bild


Betrifft: AW: Nur sichtbare Zellen addieren
von: IngoG
Geschrieben am: 17.11.2003 12:04:51

HAllo Egon,

meines wissens gibts nur die Funktion teilergebnis(), um den Filter abzufragen.

Du kannst aber zB folgendermaßen vorgehen:

=SUMMENPRODUKT((TEILERGEBNIS(3;BEREICH.VERSCHIEBEN($A$1;ZEILE($A$2:$A$6)-1;0))>0)*($B$2:$B$6)/($C$2:$C$6))

der Kniff mit bereich.verschieben() ist notwendig, weil summenprodukt() (oder auch matrixfunktionen)den Bereich einzeln durchlaufen müssen, teilergebnis als 2. parameter aber einen Range erwartet und keine einzelen Zelle...

Ich hoffe, das hilft dir etwas weiter

Gruß Ingo


Bild


Betrifft: AW: Nur sichtbare Zellen addieren
von: Egon
Geschrieben am: 17.11.2003 20:38:22

Hallo Ingo,

dass muss ich mir 'mal in Ruhe ansehen.

Vielen Dank für Deine Antwort

Egon


Bild

Beiträge aus den Excel-Beispielen zum Thema " Nur sichtbare Zellen addieren"