Anzeige
Archiv - Navigation
1252to1256
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Bestimmte Zellen addieren

Bestimmte Zellen addieren
Frank
Hallo zusammen,
hier erstmal meine Datei:
https://www.herber.de/bbs/user/79141.xls
Ich möchte die Zahlen, die in den Zeilen 15,25 und 35 addieren. Das ganze In Abhängigkeit davon, ob in D4 bis E6 der jeweiligen Zeile eine 1 oder eine 0 zugeordnet ist. Außerdem möchte ich in Zelle C2 entscheiden können, ob Spalte 1 oder 2 addiert werden soll.
Das ganze ist ein vereinfachtes Besipiel mit 3 Zeilen. Ich suche nach einer Lösung, die ausweitbar auf 20 Zeilen ist. Ein einfaches Checken jeder Zeile einzeln ist mir zu mühsam und die Formel würde wohl sehr lang werden...
Danke!
Frank

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Bestimmte Zellen addieren
29.02.2012 14:26:23
Rudi
Hallo,
so?
 ABCDEF
1      
2 Spalte1   
3    addieren?1=ja; 0=nein
4   15110
5   25150
6   3500

ZelleFormel
F4=INDEX(A:B;D4;$C$2)*E4
F5=INDEX(A:B;D5;$C$2)*E5
F6=INDEX(A:B;D6;$C$2)*E6

Gruß
Rudi
Anzeige
AW: Bestimmte Zellen addieren
29.02.2012 14:31:36
Frank
danke schonmal, aber am liebsten in EINER formel und nicht einfach durch addieren der drei elemente....wenn ich 20 zeilen hätte, würde es sicher sehr unübersichtlich werden...
AW: Bestimmte Zellen addieren
29.02.2012 15:08:15
Rudi
Hallo,
da fällt mir nur was mit ner Hilsspalte ein.
 ABCDEF
1      
2 Spalte1   
3    addieren?1=ja; 0=nein
4   15160
5   251 
6   350 
7      
13      
14      
151081   
1613    
1726    

ZelleFormel
F4{=SUMME(WENN(ISTZAHL(C15:C100);INDEX(A15:B100;;C2)*C15:C100;0))}
C15=WENN(ISTZAHL(VERGLEICH(ZEILE();$D$4:$D$6;));SVERWEIS(ZEILE();$D$4:$E$6;2;);"")
C16=WENN(ISTZAHL(VERGLEICH(ZEILE();$D$4:$D$6;));SVERWEIS(ZEILE();$D$4:$E$6;2;);"")
C17=WENN(ISTZAHL(VERGLEICH(ZEILE();$D$4:$D$6;));SVERWEIS(ZEILE();$D$4:$E$6;2;);"")
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.

Gruß
Rudi
Anzeige

303 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige