Microsoft Excel

Herbers Excel/VBA-Archiv

Summenformel mit Einbettung eines Zellinhaltes

Betrifft: Summenformel mit Einbettung eines Zellinhaltes von: Christian Gasser
Geschrieben am: 12.11.2014 17:20:30

Hallo,

ich habe in Zelle a1 einen Werte zwischen 1 - 12
gibt es nun eine einfache Formel (ohne Wenn() oder VBA, da ist mir klar wie's geht), bei der ich bei Wert 1 eine Summe a3:a3, bei Wert 2 eine Summe a3:b3, ..., also je nach Zahl so viele Spalten zusammenrechnen lassen kann?

Besten Dank, und einen schönen Abend
Chrigu

  

Betrifft: AW: Summenformel mit Einbettung eines Zellinhaltes von: hary
Geschrieben am: 12.11.2014 17:29:13

Moin
Eine Moeglichkeit:



Tabelle1

 ABCDE
1410   
2     
312345

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
B1=SUMME(BEREICH.VERSCHIEBEN(A3;;;;A1))  =SUM(OFFSET(R[2]C[-1],,,,RC[-1]))

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: AW: Summenformel mit Einbettung eines Zellinhaltes von: Christian Gasser
Geschrieben am: 12.11.2014 18:10:15

Hej,
das passt ja super und erspart mir eine ellenlange "wenn"-formel.

Besten Dank und einen schönen Abend


  

Betrifft: einfacher mit INDEX() ... von: neopa C (paneo)
Geschrieben am: 12.11.2014 18:26:18

Hallo Christian,

... ohne die volatile Funktion BEREICH.VERSCHIEBEN() so: =SUMME(A3:INDEX(3:3;A1))

Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Summenformel mit Einbettung eines Zellinhaltes"