Microsoft Excel

Herbers Excel/VBA-Archiv

Pivottabelle über Zellen mit Buchstaben als Inhalt | Herbers Excel-Forum


Betrifft: Pivottabelle über Zellen mit Buchstaben als Inhalt von: H-M Schulz
Geschrieben am: 08.02.2012 16:39:21

Hi,

ich mache Planungen von Mitarbeitern x Projekten x Arbeitsauslastung (in %).
Teilweise erfolgen an Stelle der %-Werte auch Eintragungen wie "D" für Dienstreise in die Zellen.
Die Planungen werden per Pivottabelle ausgewertet. Klappt prima.
Die "D"s werden bei der Pivot-Berechnung automatisch als Null interpretiert.

Wie kann ich in die Summenfunktion eingreifen, um "D" für die Summierung intern als einen numerischen Wert, bspw. 120%, zu interpretieren. Dazu würde ich gern die Ergebnisfelder in der Pivottabelle, in die ein "D" / 120% eingefossen ist, per Formatierung hervorheben lassen.
(In die Tabelle immer 120% eintragen fällt leider flach.)

Danke für eure Lösungs-Ideen...

  

Betrifft: Nur per Hilfsspalte mit Wertematrix von: NoNet
Geschrieben am: 08.02.2012 17:33:47

Hallo HM,

das ist leider nicht möglich : In der PIVOT-Tabelle kannst Du nicht Werte "interpretieren" :-(

Workaround : Erstelle eine Hilfsspalte mit folgender Funktion :

=WENN(ISTZAHL(B2);B2;VERWEIS(B2;{"D";"F";"U";"X"};{1,2;2;3,5;7}))

Spalte B ist die Spalte mit den %-Werten bzw. "D" oder einer der anderen Buchstaben aus der Matrix {"D";"F";"U";"X"}, die Werte der Matrix {1,2;2;3,5;7} sind die dazu gehörenden numerischen Werte (z.B. U => 3,5 => 350%).

Verwende nun die Werte dieser Hilfsspalte in der PIVOT-Tabelle.

Gruß, NoNet


  

Betrifft: Man kann aber 120% per Format auch als D ... von: Luc:-?
Geschrieben am: 08.02.2012 19:18:52

…erscheinen lassen, H-M!
Da es sicher nicht oppurtun sein wird, das so eintragen zu lassen, wäre eine entsprechende Autokorrektur sicher hilfreich: Ein eingegebenes D# wird so automatisch durch bspw -1,2 (bzw -120%), das per Zellformat 0%_-;[=-1,2]D_-; _-;@ optisch als D erscheint, ersetzt. Bei Folgerechnungen muss nur beachtet wdn, dass dieses D eine negative Zahl ist.
Gruß Luc :-?


  

Betrifft: Allerdings sind im Bsp keine neg% mögl! owT von: Luc:-?
Geschrieben am: 08.02.2012 19:20:46

:-?


Beiträge aus den Excel-Beispielen zum Thema "Pivottabelle über Zellen mit Buchstaben als Inhalt"