STUNDEN IN EINEM ZEITRAUM ERRECHNEN

Bild

Betrifft: STUNDEN IN EINEM ZEITRAUM ERRECHNEN von: FELIX
Geschrieben am: 04.02.2005 15:11:36

HALLO.

MEIN VORHABEN IST ES IN SPALTE [I 25%] DIE STUNDEN ZU ERRECHNEN FÜR DIE ICH IN EINEM ZEITRAUM ZWISCHEN 20:00 UND 00:00 ZUSCHLÄGE ERHALTE.

KANN MIR BITTE EINER BEI DER FORMEL HELFEN? ICH HAB KEINEN PLAN MEHR ...

FEBRUAR 2005
 ABCDEFGHI
2 DatumvonbisStundenPauseArbeitsstd.Feiertag25%
3Di01.02.200515:0022:0070,56,5 1,08
Formeln der Tabelle
A3 : =+B3
E3 : =WENN(ODER(C3="K";C3="U");8;WENN(ODER(C3="F";C3="AT");0;WENN(D3<C3;D3+1-C3;D3-C3)*24))
F3 : =WENN(ODER(C3="K";C3="F";C3="U";C3="AT");0;WENN(E3<5;0;WENN(E3<10;0,5;WENN(E3<15;1;1,5))))
G3 : =SUMME(E3-F3)
I3 : =WENN(ODER(C3<O20;D3<O21);WENN(ODER(D3>O20;D3<C3);(D3+1-O20));0)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


FEBRUAR 2005
 NOPQ
18ZUSCHLÄGE   
19    
20Nacht ab  20:0025% 
21Nacht ab 00:0040%0,00
Formeln der Tabelle
Q21 : =SUMME(J3:J33)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Bild


Betrifft: keine AW - nur Vormerkung - owT von: Luc
Geschrieben am: 04.02.2005 15:17:03




Bild


Betrifft: AW: Stunden in einem Zeitraum erfassen von: Matthias G
Geschrieben am: 04.02.2005 15:34:51

Hallo Felix,

1. Deine Shift-Taste klemmt
2. Ich hab mal eine VBA-Funktion geschrieben, die die Schnittmenge zweier Zeiträume errechnet:
' Beginn, Ende: Zeitraum
' Z1, Z2: überschneidung mit diesem Zeitraum
Function ZeitIn(Beginn As Date, Ende As Date, Z1 As Date, Z2 As Date) As Date
' Über Nacht: Ende +24 Std.
If Z2 < Z1 Then Z2 = Z2 + 1
If Ende < Beginn Then Ende = Ende + 1
If Beginn <= Z1 Then
    If Ende <= Z1 Then ZeitIn = 0
    If Ende > Z1 And Ende <= Z2 Then ZeitIn = Ende - Z1
    If Ende > Z2 Then ZeitIn = Z2 - Z1
ElseIf Beginn > Z1 And Beginn <= Z2 Then
    If Ende <= Z2 Then ZeitIn = Ende - Beginn
    If Ende > Z2 Then ZeitIn = Z2 - Beginn
ElseIf Beginn > Z2 Then
    ZeitIn = 0
End If
    
End Function
Ich hoffe, das hilft dir weiter!

Gruß Matthias


Bild


Betrifft: AW: Stunden in einem Zeitraum erfassen von: FELIX
Geschrieben am: 04.02.2005 16:59:47

danke Matthias G für deine hilfe. leider kenne ich mich mit vba gar nicht aus( noch weniger als mit formeln), deswegen wäre es nett wenn du mir erklären könntest wie ich den code an mein vorhaben anpasse. lieber wäre mir eine einfache formel ohne vba...

gruss felix

ps. hab die shift taste ausgebaut


Bild


Betrifft: AW: Stunden in einem Zeitraum erfassen von: r.sch.
Geschrieben am: 04.02.2005 22:57:23

Hej Felix,

versuch 's hiermit:

=WENN(D3>ZEIT(20;0;0);D3-ZEIT(20;0;0);0)*25%

damit erfaßt du die Stunden über 20:00, für eine Abgrenzung nach oben (24:00) kannst du nach dem gleichen Muster verfahren.

Gruß aus 'm Vorharz
Reinhard


 Bild

Beiträge aus den Excel-Beispielen zum Thema "STUNDEN IN EINEM ZEITRAUM ERRECHNEN"