Makro für fortlaufende Nummerierung

Bild

Betrifft: Makro für fortlaufende Nummerierung
von: Max K.
Geschrieben am: 13.03.2005 19:41:34
Hallo,
in einer Liste werden von B1 -B50 Produkte mit einem X markiert. Excel soll
danach in Spalte A fortlaufend nummerieren, aber nur dort wo in Spalte B ein
X gesetzt wurde.
Bspw. wurden die Produkte in B5, B18 und B33 mit einem X versehen. Mit dem Makro
soll es dann so aussehen: 1.) X bei B5, 2.) X bei B18, 3.) X bei B33.
Wenn es nur ohne Punkt oder Klammer geht ist das egal.
Hat jemand eine Lösung dafür?
Falls ja, schon mal vielen Dank im Voraus ;))
Gruß
Max

Bild

Betrifft: Formel für fortlaufende Nummerierung
von: Beate Schmitz
Geschrieben am: 13.03.2005 19:58:16
 
 AB
11.)x
2  
3  
42.)x
5  
63.)x
7  
84.)x
95.)x
Formeln der Tabelle
A1 : =WENN(B1="";"";TEILERGEBNIS(3;B$1:B1)*1&".)")
A2 : =WENN(B2="";"";TEILERGEBNIS(3;B$1:B2)*1&".)")
A3 : =WENN(B3="";"";TEILERGEBNIS(3;B$1:B3)*1&".)")
A4 : =WENN(B4="";"";TEILERGEBNIS(3;B$1:B4)*1&".)")
A5 : =WENN(B5="";"";TEILERGEBNIS(3;B$1:B5)*1&".)")
A6 : =WENN(B6="";"";TEILERGEBNIS(3;B$1:B6)*1&".)")
A7 : =WENN(B7="";"";TEILERGEBNIS(3;B$1:B7)*1&".)")
A8 : =WENN(B8="";"";TEILERGEBNIS(3;B$1:B8)*1&".)")
A9 : =WENN(B9="";"";TEILERGEBNIS(3;B$1:B9)*1&".)")
 

Gruß,
Beate
Bild

Betrifft: AW: Formel für fortlaufende Nummerierung
von: Max K.
Geschrieben am: 13.03.2005 20:12:57
Hallo Beate,
vielen Dank für die schnelle Hilfe!
Damit ist mein Problem gelöst, Suuuuupiiiiii ;-)))
Dir noch einen schönen Abend!
Gruß
Max
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Makro für fortlaufende Nummerierung"