Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1484to1488
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Fortlaufende Nummerierung aus gefilterter Liste

Fortlaufende Nummerierung aus gefilterter Liste
04.04.2016 16:14:07
Lens
Hallo wertes Forum,
ich habe folgendes Excel Problem. In Spalte B habe ich zahlreiche (ca.500) Daten (Zeitpunkte im Format TT.MM.JJJJ HH:MM:SS). In Spalte C findet sich eine Nr. welche genau einem Objekt zugeordnet werden kann (insgesamt acht verschiedene Nummern). Jedes Objekt kommt n mal vor zu jew. unterschiedlichen Zeitpunkten innerhalb eines Tages.
Nun mein Problem. In Spalte A soll automatisiert eine fortlaufende Nummerierung stattfinden, welche bei Objekt A mit dem frühesten Zeitpunkt eine 1, bei Objekt A mit dem darauffolgenden Zeitpunkt eine 2 und so weiter. Bisher gehe ich so vor, dass ich nach der Objektnr. filtere und manuell die Zahlen 1-n eintrage um im Anschluss die Daten weiter verwerten zu können. Diesen manuellen Aufwand würde ich mir gerne sparen.
Über einen Tipp bzw. Lösungsvorschlag würde ich mich sehr freuen.

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Fortlaufende Nummerierung aus gefilterter Liste
04.04.2016 16:15:28
SF
Hola,
ist Spalte B aufsteigend sortiert?
Gruß,
steve1da

AW: Fortlaufende Nummerierung aus gefilterter Liste
04.04.2016 18:26:39
fcs
Hallo Lens,
die Nummerierung kannst du per Formel erreichen. Bei 500 Zeilen ist die Formel noch akzeptabel schnell.
Gruß
Franz
Tabellenblattname: Tabelle1
A             B              C
1  Nr            Datum Zeit   Objekt
2   1   04.04.2016 11:20:42        1
3   1   04.04.2016 07:56:07        4
4   2   04.04.2016 15:17:17        1
5   1   04.04.2016 14:36:31        2
6   3   04.04.2016 12:00:44        1
7   1   04.04.2016 12:14:48        3
8   4   04.04.2016 05:52:46        1
9   2   04.04.2016 00:06:30        4
10   3   04.04.2016 13:50:51        4
11   4   04.04.2016 06:41:19        4
12   2   04.04.2016 15:53:27        2
13   2   04.04.2016 14:30:02        3
14   5   04.04.2016 16:43:23        4
15   6   04.04.2016 20:04:09        4
16   1   04.04.2016 10:35:07        5
Benutzte Formeln:
A2:  =ZÄHLENWENN($C$1:$C2;C2)
A3:  =ZÄHLENWENN($C$1:$C3;C3)
A4:  =ZÄHLENWENN($C$1:$C4;C4)
usw

Anzeige

302 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige