Microsoft Excel

Herbers Excel/VBA-Archiv

Fortlaufende Zeilen-Nummerierung einfügen


Betrifft: Fortlaufende Zeilen-Nummerierung einfügen von: Juergen
Geschrieben am: 03.05.2017 11:35:49

Hallo zusammen,

ich bräuchte Hilfe oder einen Tipp zu folgenden Umstand:

ich habe ein Tabellenblatt mit unterschiedlichen Inhalten/Werten in der Spalte "C".
Die Einträge werden durch leere "Zellen" unregelmäßig unterbrochen.

Jetzt benötige ich einen fortlaufende Nummerierung in der ersten Spalte zu allen befüllten Zell-Werten in "C".

Ich bin mal soweit gekommen, dass mit dem Befehl =WENN(C1<>"";"0001";"") ich einen Nummern-Wert in die Spalte "A" bei Zellinhalt in Spalte "C" bekomme, aber natürlich keinen fortlaufenden. Wie könnte ich das anstellen!?

Hier mein Beispiel:
https://www.herber.de/bbs/user/113275.xlsm

Gruss & Danke,
Juergen

  

Betrifft: AW: Fortlaufende Zeilen-Nummerierung einfügen von: EtoPHG
Geschrieben am: 03.05.2017 11:40:38

Hallo Juergen,

=WENN(C11<>"";ANZAHL2(C$1:C11);"")
Gruess Hansueli


  

Betrifft: AW: Fortlaufende Zeile... von: EtoPHG
Geschrieben am: 03.05.2017 11:42:03

ooops, 2 1 zuviel

in A1 und runterkopieren:

=WENN(C1<>"";ANZAHL2(C$1:C1);"")
Gruess Hansueli


  

Betrifft: AW: Fortlaufende Zeile... von: EtoPHG
Geschrieben am: 03.05.2017 11:42:26

ooops, 2 1 zuviel

in A1 und runterkopieren:

=WENN(C1<>"";ANZAHL2(C$1:C1);"")
Gruess Hansueli


  

Betrifft: AW: Fortlaufende Zeile... von: Juergen
Geschrieben am: 03.05.2017 11:53:40

Hallo Hansueli,

herzlichen Dank für die prompte Lösung! Wieder was gelernt :)
Anscheinend gibt's nix was es nicht gibt in der Zellformel.

Gruss & Danke,
Juergen

btw: ...tolles und hilfsbereites Forum hier! Danke.


Beiträge aus den Excel-Beispielen zum Thema "Fortlaufende Zeilen-Nummerierung einfügen"