SVERWEIS/INDEX mehrere Treffer

Bild

Betrifft: SVERWEIS/INDEX mehrere Treffer
von: Johannes Schmitz
Geschrieben am: 06.07.2015 15:22:15

Hallo zusammen,
ich würde gerne eine SVERWEIS bzw. INDEX-VERGLEICH Formel erstellen, die mir nicht nur einen Treffer liefert, sondern mehrere.
Ich habe einen Kenner, dem eine oder auch mehrere Nummern zugeordnet sind.
Mit dem klassischen SVERWEIS oder INDEX-VERGLEICH liefert mir Excel nur den ersten Treffer.
Im Anhang findet ihr eine Datei, die das Problem exemplarisch darstellt.
Über jede Hilfe freue ich mich.
Viele Grüße,
Johannes
https://www.herber.de/bbs/user/98664.xls

Bild

Betrifft: AW: SVERWEIS/INDEX mehrere Treffer
von: {Boris}
Geschrieben am: 06.07.2015 15:29:55
Hi Johannes,
ohne die Datei geöffnet zu haben: http://excelformeln.de/formeln.html?welcher=28
VG, Boris

Bild

Betrifft: in Excel 2010 mit WENNFEHLER() und AGGREGAT()
von: der neopa C
Geschrieben am: 06.07.2015 15:37:04
Hallo Johannes,
... Formel einfach nach rechts und unten ziehend kopieren:

 ABCDE
1Kenner1. Zuordnung (1. Treffer)2. Zuordnung (2. Treffer)3. Zuordnung (3. Treffer)4. Zuordnung (4. Treffer)
2195/55 R16 91V439560694824495835394056
3175/70 R14 84T346024656503939654 
4205/65 R15 94H630673945694349596 
5215/65 R16 98V548634856605  

Formeln der Tabelle
ZelleFormel
B2=WENNFEHLER(INDEX($H:$H;AGGREGAT(15;6;ZEILE(A$1:A$99)/($G$1:$G$19=$A2)/($A2>0); SPALTE(A1))); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: zum Nachvollziehen ohne Datei nun auch mit Daten
von: der neopa C
Geschrieben am: 06.07.2015 15:43:12
Hallo,
... so:

 ABCDEFGH
1KennerTreffer 1Treffer 2Treffer 3Treffer 4 KennerProduktnummer
2195/55 R16 91V439560694824495835394056 195/55 R16 91V439560
3175/70 R14 84T346024656503939654  175/70 R14 84T346024
4205/65 R15 94H630673945694349596  205/65 R15 94H630673
5215/65 R16 98V548634856605   195/55 R16 91V694824
6      175/70 R14 84T656503
7      195/55 R16 91V495835
8      215/65 R16 98V548634
9      215/65 R16 98V856605
10      175/70 R14 84T939654
11      205/65 R15 94H945694
12      195/55 R16 91V394056
13      205/65 R15 94H349596
14        

Formeln der Tabelle
ZelleFormel
B2=WENNFEHLER(INDEX($H:$H;AGGREGAT(15;6;ZEILE(A$1:A$99)/($G$1:$G$19=$A2)/($A2>0); SPALTE(A1))); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS/INDEX mehrere Treffer"