Denkknoten INDEX VERGLEICHEN SVERWEIS

Bild

Betrifft: Denkknoten INDEX VERGLEICHEN SVERWEIS
von: Christian Fischer
Geschrieben am: 18.09.2015 22:37:11

guten abend liebe excelfreunde,
zunächst mal ein großes Lob und Dankeschön an die Betreiber dieses weltklasse Forums!
Ich bräuchte eure erstmalig Eure Hilfe, da ich vieles probiert und leider wieder verwerfen musste.
Es geht um eine Excel Tabelle (Schichtplan) mit 30-40 Zeilen und zwischen 60-100 Spalten. Alle Zellen in dieser Matrix, die den Text "OFFEN" enthalten, möchte ich nun nacheinander auflisten inkl. jeweiliger Spaltenüberschrift (Schicht ID) und Zeilenanfang (stellt den Tag dar).
Geholfen hat mir folgender Foreneintrag, jedoch denke ich ist dieser Ansatz nicht ganz zu Ende gedacht, bzw. es fehlt mir was. Denn ich habe mehr als nur eine Spalte, und den Wechsel von einer zur nächsten... ich stecke jedenfalls fest.
https://www.herber.de/forum/archiv/788to792/788845_SVERWEIS_nicht_nur_den_erstgefundenen_ausgeben.html
evtl. habt ihr einen anderen Ansatz hierfür?
viele grüße christian
hier meine probedatei
https://www.herber.de/bbs/user/100266.xlsx

Bild

Betrifft: AW: Denkknoten INDEX VERGLEICHEN SVERWEIS
von: Sepp
Geschrieben am: 18.09.2015 22:55:23
Hallo Christian,
so?
Tabelle1

 ABCDEFGHIJKLM
1 Quelldaten:           
2 301302303304306308610708    
31            
42 OFFEN  OFFEN     3022
53          3025
64  OFFEN       3026
75 OFFEN  OFFEN OFFEN   3027
86 OFFEN        30213
97 OFFEN        30214
108          30215
119   OFFEN      30223
1210          30226
1311     OFFEN    30230
1412          3034
1513 OFFEN        30318
1614 OFFEN OFFEN      3049
1715 OFFEN        30414
1816     OFFEN    30427
1917          3062
2018  OFFEN       3065
2119    OFFEN     30619
2220      OFFEN   30622
2321          30630
2422    OFFEN     30811
2523 OFFEN        30816
2624          6105
2725          61020
2826 OFFEN    OFFEN   61026

Formeln der Tabelle
ZelleFormel
L4=WENNFEHLER(INDEX($B$2:$I$2;AGGREGAT(15;6;SPALTE($A:$H)/($B$3:$I$33="OFFEN"); ZEILE(A1))); "")
M4=WENN(L4="";"";INDEX($A$3:$A$33;AGGREGAT(15;6;ZEILE($A$1:$A$30)/($B$2:$I$2=L4)/($B$3:$I$33="OFFEN"); ZÄHLENWENN($L$4:$L4;L4))))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp


Bild

Betrifft: AW: Denkknoten INDEX VERGLEICHEN SVERWEIS
von: Christian Fischer
Geschrieben am: 18.09.2015 23:05:21
Hallo und guten Abend Sepp!
der oberhammer! genau so! wärst jetzt ums eck, könntma auf a Maß auf´d wiesn!
aber auch so drück ich Dir meinen herzlichsten, zutiefst respektierenden DANK aus, lieber Sepp.
Aggregat scheint ja mächtig viel zu können. i like :)
viele grüße christian

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Denkknoten INDEX VERGLEICHEN SVERWEIS"