Microsoft Excel

Herbers Excel/VBA-Archiv

Textbestandteil suchen per WENN & ODER

Betrifft: Textbestandteil suchen per WENN & ODER von: Karsten
Geschrieben am: 10.08.2020 13:59:38

Hallo zusammen,


aus einer Tabelle mit über 13.000 Zeilen benötige ich den Inhalt aus Spalte A, WENN in Spalte D ODER E der "Suchtext" als Textbestandteil vorhanden ist.


Beispiel: Wenn "suchtext" im Text von D oder E enthalten ist, gib den Inhalt von A aus, ansonsten leer.

Konkret: Wenn im Text der Zelle in D oder E der Textbestandteil "Apotheke" enthalten ist, dann den Inhalt von A ausgeben, ansonsten nichts.


=WENN(ODER(SUCHEN(D3:D13426;"*Apotheke*");SUCHEN(E3:E13426;"*Apotheke*"));A3;"")

gibt leider den Fehlerwert #WERT! aus.

Ich kann aber leider nicht ermitteln, wo der Fehler liegt.


Ich hoffe, hier kann mir jemand helfen?


Vielen Dank im Voraus und Beste Grüße,

Karsten

Betrifft: AW: Textbestandteil suchen per WENN & ODER
von: SF
Geschrieben am: 10.08.2020 14:10:07

Hola,

ungetestet:
=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$3:$A$13000)/(ISTZAHL(SUCHEN("apotheke";$D$3:$E$13000))); ZEILE(A1)));"")

Gruß,
steve1da

Betrifft: AW: Textbestandteil suchen per WENN & ODER
von: Rudi Maintaire
Geschrieben am: 10.08.2020 14:10:24

Hallo,
Matixformel:
{=INDEX(A3:A13426;VERGLEICH("*apotheke*" &"*apotheke*";D3:D13426&E3:E13426;))}

Gruß
Rudi

Betrifft: AW: bei Einsatz von AGGREGAT() ...
von: neopa C
Geschrieben am: 10.08.2020 15:21:09

Hallo Karsten,

... wäre ausreichend:

=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(A$3:A$13426)/SUCHEN("Apotheke";D$3:E$13426)^0;1));"")


Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Textbestandteil suchen per WENN & ODER"