Microsoft Excel

Herbers Excel/VBA-Archiv

Nach Eintrag suchen und kennzeichnen

Betrifft: Nach Eintrag suchen und kennzeichnen von: Andreas
Geschrieben am: 14.09.2020 12:40:22

Hallo zusammen,

ich weiß nicht wie ich es so recht beschreiben soll - deshalb hier mal am Bsp:


5494812

5499037 x

5499037

5499417

5499417

5441976

5444937

5444937

5444937


In einer Tabelle gibt es eine Spalte mit Zahlen, die ungeordnet mehrfach vorkommen. Wenn eine dieser Zahlen in der Nachbarspalte mit x gekennzeichnet ist, sollen automatisch alle ein x erhalten. Am liebsten würde ich das im Nachhinein per Makro lösen. Hat da jemand eine Idee, wie das gehen könnte? Der Fall tritt mehrfach auf, also nur mit suchen und ersetzen wird es nicht gehen.

Würde mich freuen, wenn mir jemand helfen kann :-)


VG

Andreas

Betrifft: AW: Nach Eintrag suchen und kennzeichnen
von: Daniel
Geschrieben am: 14.09.2020 12:54:28

Hi
ohne Makro könntest du in Spalte C dies mit folgender Formel tun:

=Wenn(ZählenWenns(A:A;A1;B:B;"x");"x";"")

ein Makro könnte dann diese Formel einfügen, kopieren und durch den Wert ersetzen.

Gruß Daniel

Betrifft: AW: Nach Eintrag suchen und kennzeichnen
von: Andreas
Geschrieben am: 14.09.2020 13:25:57

Hallo Daniel,
vielen Dank. Im Moment kommt da überall 0 raus. Hat das mit dem Zellformat zu tun?

VG
Andreas

Betrifft: AW: Nach Eintrag suchen und kennzeichnen
von: Daniel
Geschrieben am: 14.09.2020 13:42:38

HI
keine Ahnung.
da müsste ich mir die Datei mal anschauen.
bei Meiner Formel kann nur "x" oder Leerstring rauskommen.
wenn du 0 als Ergebnis bekommst, hast du eine andere Formel verwendet.
Gruß Daniel

Betrifft: mit Formel ...
von: Matthias L
Geschrieben am: 14.09.2020 12:57:30

Hi,

Tabelle1

 AB
15494812 
25499037x
35499037x
45499417x
55499417x
65441976 
75444937x
85444937x
95444937x

Formeln der Tabelle
ZelleFormel
B1=WENN(ZÄHLENWENN($A$1:$A$9;A1)>1;"x";"")
B2=WENN(ZÄHLENWENN($A$1:$A$9;A2)>1;"x";"")
B3=WENN(ZÄHLENWENN($A$1:$A$9;A3)>1;"x";"")
B4=WENN(ZÄHLENWENN($A$1:$A$9;A4)>1;"x";"")
B5=WENN(ZÄHLENWENN($A$1:$A$9;A5)>1;"x";"")
B6=WENN(ZÄHLENWENN($A$1:$A$9;A6)>1;"x";"")
B7=WENN(ZÄHLENWENN($A$1:$A$9;A7)>1;"x";"")
B8=WENN(ZÄHLENWENN($A$1:$A$9;A8)>1;"x";"")
B9=WENN(ZÄHLENWENN($A$1:$A$9;A9)>1;"x";"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß

Betrifft: falsch verstanden ... owT
von: Matthias L
Geschrieben am: 14.09.2020 13:00:05



Betrifft: AW: Nach Eintrag suchen und kennzeichnen
von: Daniel
Geschrieben am: 14.09.2020 13:01:21

Hi
mit VBA vielleicht so, wenn man icht mit Formel und Hilfsspalte arbeiten will:
Sub test()
Dim Wert
Dim Zelle As Range
For Each Zelle In Columns(2).SpecialCells(xlCellTypeConstants, 2)
    Wert = Zelle.Offset(0, -1).Value
    With Columns(1)
        .Replace Wert, True, xlWhole
        With .SpecialCells(xlCellTypeConstants, 4)
            .Offset(0, 1).Value = Zelle.Value
            .Value = Wert
        End With
    End With
Next
End Sub

Gruß Daniel

Betrifft: AW: Nach Eintrag suchen und kennzeichnen
von: Andreas
Geschrieben am: 14.09.2020 14:33:09

nochmals Danke, geht schon etwas :-)
aber ich will auch etwas lernen. Wofür steht denn in der Zeile:
With .SpecialCells(xlCellTypeConstants, 4)
die 4 ?

VG
Andreas

Betrifft: AW: Nach Eintrag suchen und kennzeichnen
von: Dieter(Drummer)
Geschrieben am: 14.09.2020 14:39:45

Hallo Andreas,

evtl. ist das für dich eine Erklärung:
https://www.herber.de/forum/archiv/240to244/243721_xlCellTypeConstants.html

Gruß, Dieter(Drummer)

Betrifft: AW: Nach Eintrag suchen und kennzeichnen
von: Andreas
Geschrieben am: 14.09.2020 16:24:20

Hallo Dieter,
danke - das hilft mir weiter :-)

VG

Betrifft: AW: Nach Eintrag suchen und kennzeichnen
von: Daniel
Geschrieben am: 14.09.2020 14:44:44

Hi
über diesen Zahlenwert steuerst du, was du auswählen willst, Zahlen, Texte Wahrheitswerte oder Fehlerwerte, entsprechend der Menüfunktion START - BEARBEITEN - SUCHEN UND AUSWÄHLEN - INHALTE.

welche Zahl für was steht, kannst du leicht mit dem Recorder rausfinden.
VBA arbeitet hier mit einfachen Zahlen anstelle von ENumerationskonstanten, vermutlich weil man hier verschiedene Möglichkeiten kombinieren kann und es für die Kombinationen keine ENumeration gibt.

Gruß Daniel

Betrifft: AW: Nach Eintrag suchen und kennzeichnen
von: Andreas
Geschrieben am: 14.09.2020 16:25:22

Danke!

Beiträge aus dem Excel-Forum zum Thema "Nach Eintrag suchen und kennzeichnen"