nach Wort oder zahl suchen und Summe

Bild

Betrifft: nach Wort oder zahl suchen und Summe
von: Thomas
Geschrieben am: 09.07.2015 00:12:22

Hallo zusammen,
Momentan hab ich nur Probleme und brauche eure Hilfe.
Tabelle2
SPALTEC2 steht 250 drin
SPALTED2 steht hoch drin
SpalteE2 steht 124 drin
Jetzt sollen in der Tabelle 1 Spalte C stehen die Werte. Aber so
C3 = KLK_250 und dann 5 Leerzeichen
C4= KLK_hoch und dann 5 Leerzeichen
C5= LZLZS_250 und dann 4 Leerzeichen
Usw.
Jetzt soll alle zahlen mit 250 die Anzahl gezählt werden.
Hab scho mit der Formel Rechts gemacht aber die unterschiedlichen Leerzeichen ist doof.Da ich dann statt hoch nur och habe .
Jemand eine Idee?
Thomas

Bild

Betrifft: vorher einfach Glätten
von: Matthias L
Geschrieben am: 09.07.2015 00:22:37
Hallo Thomas
Benutze doch Glätten

 CD
2 Länge
3KLK_250     12
4KLK_hoch     13
5  
6KLK_2507
7KLK_hoch8

Formeln der Tabelle
ZelleFormel
D3=LÄNGE(C3)
D4=LÄNGE(C4)
C6=GLÄTTEN(C3)
D6=LÄNGE(C6)
C7=GLÄTTEN(C4)
D7=LÄNGE(C7)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: vorher einfach Glätten
von: Thomas
Geschrieben am: 09.07.2015 00:26:37
Hallo Matthias,
so gut kenne ich mich nicht so aus.
Aber wie zähle ich das zusammen?

Bild

Betrifft: vorher Glätten dann Zählen
von: Matthias L
Geschrieben am: 09.07.2015 00:40:06
Hallo
Hier ist eine Variante

 CDE
2String mit 5 Leerzeichen am EndeLänge mit 5 Leerzeichen am Ende 
3KLK_250     12 
4KLK_hoch     13 
5LZLZS_250     14 
6   
7String ohne 5 Leerzeichen am EndegeglättetAuswertung
8KLK_2507WAHR
9KLK_hoch8 
10LZLZS_2509WAHR
11  2

Formeln der Tabelle
ZelleFormel
D3=LÄNGE(C3)
D4=LÄNGE(C4)
D5=LÄNGE(C5)
C8=GLÄTTEN(C3)
D8=LÄNGE(C8)
E8=WENNFEHLER(--RECHTS(C8;3)=250;"")
C9=GLÄTTEN(C4)
D9=LÄNGE(C9)
E9=WENNFEHLER(--RECHTS(C9;3)=250;"")
C10=GLÄTTEN(C5)
D10=LÄNGE(C10)
E10=WENNFEHLER(--RECHTS(C10;3)=250;"")
E11=ZÄHLENWENN(E8:E10;WAHR)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Da gibt es mehrere Möglichkeiten, aber so kannst Du es evtl. besser nachvollziehen
Gruß Matthias

Bild

Betrifft: Wie Auswerten
von: Thomas
Geschrieben am: 09.07.2015 01:01:33
Hallo,
Wie wette ist sowas wie im tabellenblatt Auswertung aus ?
https://www.herber.de/bbs/user/98725.xls
Hoffe du kannst mir helfen da ich es unbedingt brauche
Lgthomas

Bild

Betrifft: Beitrag offen ...
von: Matthias L
Geschrieben am: 09.07.2015 01:39:30
Hallo
 Ich weiß leider nicht was Du jetzt wo zählen willst.
 Ich lass mal offen - für andere Nachtschwärmer.
 Ich habe jetzt keine Zeit mehr, sorry.
Gruß Matthias

Bild

Betrifft: AW: Wie Auswerten
von: Rolf.dW
Geschrieben am: 09.07.2015 02:23:10
Hallo Thomas,
die Angaben in deiner Mähl (00:12:22 Uhr):
Tabelle2
SPALTEC2 steht 250 drin
SPALTED2 steht hoch drin
SpalteE2 steht 124 drin
finde ich in der übermittelten Datei leider nicht.
BR
(bin ratlos)
Gruß, Rolf

Bild

Betrifft: AW: Wie Auswerten
von: Thomas
Geschrieben am: 09.07.2015 03:29:37
Hallo Rolf,
Ich die liste Datei ist original.
Die Auswertung hab ich Manuell eingeben.Aber meine richtige Datei hat 15000 Zeilen
Danke

Bild

Betrifft: AW: Wie Auswerten
von: hary
Geschrieben am: 09.07.2015 09:41:27
Moin
Meinst du so? Die Nullen sind nicht sichtbar durch Format 0;;



Auswertung

 ABCDEFGHIJKLM
3KLK4_240 00000000100
4KLK3_240 00000000100
5KLK3_CCG2 01000000650
6KLK3_180 00000000000
7KLK3_160 00000000000

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
C3:M7=SUMMENPRODUKT((Grunddaten!$B$2:$B$30=$A3)*(RECHTS(GLÄTTEN(Grunddaten!$C$2:$C$30);LÄNGE(C$2))=C$2))  =SUMPRODUCT((Grunddaten!R2C2:R30C2=RC1)*(RIGHT(TRIM(Grunddaten!R2C3:R30C3),LEN(R2C))=R2C))

Zahlenformate
Zelle Format Wert
C3:C7, D3: D4, D6: D7, E3:J7, K6:L7, L3:L4, M3:M7 '0;;0
D5, K3:K4 '0;;1
K5 '0;;6
L5 '0;;5
Zellen mit Format Standard werden nicht dargestellt

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary

Bild

Betrifft: AW: nach Wort oder zahl suchen und Summe
von: Rolf.dW
Geschrieben am: 09.07.2015 08:39:54
Moin Thomas,
in Tabelle2 (Auswertung) steht
in Zelle C2: 240 (nicht 250)
in Zelle D2: CCG2 (nicht "hoch")
in Zelle E2: 210 (nicht 124)
So what?
"250" taucht übrigens in Tabelle1 überhaupt nicht auf. Aber egal. Ich hab mal eine mögliche Lösung mit Hilfsspalte beigefügt, vielleicht reicht das ja.
https://www.herber.de/bbs/user/98727.xls
Gruß, Rolf

Bild

Betrifft: Danke an alle :-) wunderbar
von: Thomas
Geschrieben am: 09.07.2015 10:33:44
.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "nach Wort oder zahl suchen und Summe"