Herbers Excel-Forum - das Archiv

Zelle nach erster Ziffer Durchsuchen

Bild

Betrifft: Zelle nach erster Ziffer Durchsuchen
von: simon

Geschrieben am: 30.03.2005 23:15:52
Hallo Zusammen,
hab mal wieder ein kleines Problem,
habe eine Spalte in der stehen Nr. immer K 1; D 2 ; K ... also vor der Nr. steht immer noch ein Buchstabe
wie kann ich jetzt hier mit einer For next schleife auf z.B. alle Nr. die mit K beginnen zugreifen?
also es soll nicht die ganze Zelle durchsucht werden sondern nur die erste Ziffer.
Ist das möglich ?
habs schon mit einer Hilfsspalte gemacht( = Teil(B5;1;1)), wird dann aber zu groß da es bis Zeile 40000 gehen kann.
gruß simon
Bild

Betrifft: AW: Zelle nach erster Ziffer Durchsuchen
von: Josef Ehrensberger

Geschrieben am: 30.03.2005 23:26:13
Hallo Simon!
Für Spalte "A" geht das so!
Sub findeK()
Dim rng As Range
Dim sFirst As String
Dim sFind As String
sFind = "K*"
Set rng = Range("A:A").Find(What:=sFind)
If Not rng Is Nothing Then
sFirst = rng.Address
Do
MsgBox rng
Set rng = Range("A:A").FindNext(rng)
Loop While rng.Address <> sFirst
End If
Set rng = Nothing
End Sub


Gruß Sepp
P.S.: Rückmeldung nicht vergessen!


Bild

Betrifft: AW: Zelle nach erster Ziffer Durchsuchen
von: Simon
Geschrieben am: 30.03.2005 23:39:24
Hallo Josef,
ja super, sowas habe ich gesucht,
muss die gefunden Spalten ja noch weiterbearbeiten, da ist das genau das Richtige
Danke Dir.
gruß simon
Bild

Betrifft: Formellösung
von: Beate Schmitz

Geschrieben am: 30.03.2005 23:29:18
Hallo Simon,
du brauchst keine Hilfsspalte, du kannst eine dynamische Formellösung durch 2 Zellen erreichen:
 
 AB
1Suchbuchstabe:K
2Anzahl:2
3K 15 
4D 25 
5B 1 
6K 125 
7C 10 
Formeln der Tabelle
B2 : =SUMMENPRODUKT(N(LINKS(A3:A40000;1)=B1))
 


Indem du den Suchbuchstaben in B1 änderst, wirkt sich das ja auf das Formelergebnis aus.
Gruß,
Beate
 Bild
Excel-Beispiele zum Thema "Zelle nach erster Ziffer Durchsuchen"
In zweiter UserForm Werte aus erster UserForm anzeigen Zahlenformatierung mit Punkt nach der 1. Ziffer
Autofilter auch mit Ziffern von Zahlen Einen von einer Schlüsselziffer abhängigen Bereich kopieren
Im Textfeld nur Eingabe von 2 Ziffern zulassen, dann zum nächsten Zeichenfolge in Ziffern und Buchstaben aufteilen
Eingabebegrenzung und keine Zifferneingabe Ausziffern von Werten
Nach Prüfziffer abprüfen String mit Prüfziffer über Dialogeingabe erstellen