Microsoft Excel

Herbers Excel/VBA-Archiv

In zelle Wort suchen und ausgeben

Betrifft: In zelle Wort suchen und ausgeben von: Max Wess
Geschrieben am: 30.10.2020 09:41:22

Hallo Leute,


ich konnte leider nicht im Forum einen ähnlichen Beitrag finden, mitdem ich hätte arbeiten können.

Ich suche in einer Zelle nach mehreren Begriffen:

Zelle ist bspw. gefüllt mit ARAL Tankstelle Benzin, die Reihenfolge der Begriffe kann abweichen.

Jetzt suche ich nur nach dem Begriff "ARAL" und hätte diesen gern ausgegeben.

Formel: =WENN(ISTFEHLER(FINDEN("ARAL";B16)>0);WENN(ISTFEHLER(FINDEN("EPT";B16)>0);"";"EPT");"ARAL")
Ist mir bekannt und funktioniert auch. Wenn ich aber nun die Anzahl meiner Begriffe erweitern möchte, gibt Excel mir zurück, dass zu viele Argumente vorhanden sind.

Die Suchabfrage sollten aber noch um 40 Begriffe erweitert werden.


Ich hoffe, dass Sie mir weiterhelfen können.

MG

Betrifft: AW: In zelle Wort suchen und ausgeben
von: Max Wess
Geschrieben am: 30.10.2020 09:45:30

https://www.herber.de/bbs/user/141182.xlsx

Betrifft: AW:z.B. mit INDEX() und AGGREGAT() ...
von: neopa C
Geschrieben am: 30.10.2020 10:10:41

Hallo MG,

... schreibe Deine Suchbegriffe z.B. in Spalte AX

Dann für B3 folgende Formel:

=WENNFEHLER(INDEX(AX:AX;AGGREGAT(15;6;ZEILE(AX$1:AX$40)/(AX1:AX40<>"")/FINDEN(AX$1:AX$40;B3)^0;1));"")
Formel nach unten kopierbar.

Gruß Werner
.. , - ...

Betrifft: AW: AW:z.B. mit INDEX() und AGGREGAT() ...
von: Max Wess
Geschrieben am: 30.10.2020 17:38:30

Hallo Werner,

dankeschön. Das hat mir echt geholfen.
Schönes Wochenende

Betrifft: AW: bitteschön & schönes WE wünsch ich auch owT
von: neopa C
Geschrieben am: 30.10.2020 19:25:02

Gruß Werner
.. , - ...

Betrifft: das ist ein VERGLEICH andersrum
von: WF
Geschrieben am: 30.10.2020 11:09:33

Hi,

Deine 40 Begriffe stehen in G1 bis G40.

folgende Arrayformel:
{=INDEX(G:G;MIN(WENN(ISTZAHL(VERGLEICH("*"&G1:G40&"*";B16;0));ZEILE(X1:X40))))}

Salut WF

Beiträge aus dem Excel-Forum zum Thema "In zelle Wort suchen und ausgeben"