Microsoft Excel

Herbers Excel/VBA-Archiv

Index und Vergleich

Betrifft: Index und Vergleich von: Andel
Geschrieben am: 19.08.2004 11:37:36

Moin,
ich habe folgende Formel zurecht gefitschelt:
=INDEX(Tabelle2!$E$2:$E$259;VERGLEICH(Tabelle1!A20&ODER(H20;O20);Tabelle2!$A$2:$A$259&Tabelle2!$B$2:$B$259;0))

mein Problem ist - ODER (H20;O20)- ich weiss, dass es so nicht funktionieren kann. Der Wert der nötig ist um in der Tabelle2, Spalte B die richtige Zeile auszulesen, steht entweder in der Zeile h20 oder o20 der Tabelle 1. Nur wie stelle ich es an, dass Excel beide Werte überprüft und bei einer Übereinstimmung nur eines Wertes dann in Tabelle 2 den richtigen Wert ausliest?

THX Andel

  


Betrifft: AW: Index und Vergleich von: Andel
Geschrieben am: 19.08.2004 15:03:53

Ist die Frage zuleicht? Habe ich irgendwas übersehen oder doch so knifflich?


  


Betrifft: Lösung aber klobig geht´s eleganter? von: Andel
Geschrieben am: 20.08.2004 14:00:26

mit der Lösung funktioniert es aber ist doch rechts fett. Hat jemand eine Idee wie es elganter Funktioniert??

=WENN(ISTFEHLER(INDEX(Tabelle2!$E$2:$E$259;VERGLEICH(Tabelle1!A2&H2;Tabelle2!$A$2:$A$259&Tabelle2!$B$2:$B$259;0)));INDEX(Tabelle2!$E$2:$E$259;VERGLEICH(Tabelle1!A2&O2;Tabelle2!$A$2:$A$259&Tabelle2!$B$2:$B$259;0));INDEX(Tabelle2!$E$2:$E$259;VERGLEICH(Tabelle1!A2&H2;Tabelle2!$A$2:$A$259&Tabelle2!$B$2:$B$259;0)))

MfG Andel


 

Beiträge aus den Excel-Beispielen zum Thema "Index und Vergleich"