Microsoft Excel

Herbers Excel/VBA-Archiv

Zahlen vergleichen und Platz ausgeben

Betrifft: Zahlen vergleichen und Platz ausgeben von: Roland
Geschrieben am: 05.09.2020 15:32:31

Hallo zusammen,


habe folgende Problemstellung:

Ich muss eine Ergebniszahl zwischen 1 und 100 in einer vorhandenen Zahlenreihe (28 Stück) auf Gleichheit/Vorhandensein prüfen, und wenn diese Zahl in dieser Reihe vorkommt, den Platz dieser Zahl (als Platzzahl zwischen 1-28) in einer neuen Zelle ausgeben.

Ich hoffe ich habe mich verständlich ausgedrückt, zur Sicherheit anbei:


https://www.herber.de/bbs/user/140059.xlsx


Vielen Dank für eure Hilfe!

Gruß Roland

Betrifft: Index mit Vergleich & wennFormel, oder VBA
von: Matthias L
Geschrieben am: 05.09.2020 15:46:15

Hallo,

Könnte man mit Index+Vergleich+wennFormel lösen
Ich würde es mit VBA lösen.

Wäre das eine Option?

Gruß Matthias

Betrifft: AW: Index mit Vergleich & wennFormel, oder VBA
von: Roland
Geschrieben am: 05.09.2020 16:10:14

Hallo Matthias,
wenns ohne VBA geht dann reicht das.
Kannst Du mir einen Formeln-Lösungsweg aufzeichnen?
Gruß Roland

Betrifft: siehe Formel von Walter (WF) ...
von: Matthias L
Geschrieben am: 05.09.2020 16:15:45

meine Formel wäre länger gewesen, aber genauso zielführend.

Betrifft: =WENNFEHLER(VERGLEICH(I4;$D9:$AI9;0);"")
von: WF
Geschrieben am: 05.09.2020 16:04:14

Empfehlung:
benutze NIE verbundene Zellen.

WF

Betrifft: benutze NIE verbundene Zellen ?????
von: Matthias L
Geschrieben am: 05.09.2020 16:07:07

wer bestimmt das ?
.

Betrifft: das bestimmt niemand
von: WF
Geschrieben am: 05.09.2020 16:16:07

Irgendwann schnallt jeder, dass die Schrott verursachen.

WF

Betrifft: ach, und Du denkst Du bist jeder?
von: Matthias L
Geschrieben am: 05.09.2020 16:32:50

Verbundzellen haben auch Vorteile! Man muss sich nur damit beschäftigen.
Das schnallt aber nicht jeder.

Betrifft: Mediation Verbundzellen
von: lupo1
Geschrieben am: 05.09.2020 17:02:33

WF hat recht, dass die Dinger z.B. total "scheiße behindern", wenn man Zellen löschen oder einfügen will. Aber auch Bezüge werden damit nicht besonders gut.

Matthias hat recht, wenn sie z.B. rein für Formulare verwendet werden. Denn in Datenblätter gehören strenggenommen neben verbundenen Zellen auch keine Formate, Farben, Schriftarten und eigentlich auch keine Formeln. Klar, dass man das nicht 100% befolgt.

Luc hat dann noch weitergehende Berechtigungen dafür, die sich aber dem Normalo nicht erschließen.

Betrifft: AW: alternativ, einfacher mit SUMMEWENN() ...
von: neopa C
Geschrieben am: 05.09.2020 16:28:42

Hallo Roland,

... in I6: =SUMMEWENN(9:9;I4;8:8) und Formel nach rechts kopieren.

Um Egebnis-0-Werte nicht als solche anzuzeigen, formatiere die Zelle mit benutzerdefinierten Zahlenformat: 0;;

Gruß Werner
.. , - ...

Betrifft: AW: alternativ, einfacher mit SUMMEWENN() ...
von: Roland
Geschrieben am: 05.09.2020 17:37:57

DANKE Werner, funktioniert super!
Gruß Roland

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 05.09.2020 18:33:38

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Zahlen vergleichen und Platz ausgeben"