Microsoft Excel

Herbers Excel/VBA-Archiv

Transponieren mit Index und Vergleich

Betrifft: Transponieren mit Index und Vergleich von: michael k
Geschrieben am: 19.04.2015 15:43:35

Hallo,

ich schreibe heute meinen ersten Beitrag hier im Forum und hoffe, Hilfe bei einem aus meiner Sicht kniffligen Problem zu bekommen.

Ich bekomme in der Firma von einer Projektsoftware eine Importdatei zur Verfügung gestellt. Untereinander stehen dort in Spalte A die Projektnummer, in Spalte B die betroffene Abteilung und in Spalte C das Datum des Aufgabenabschlusses. In Summe gibt es 7 mögliche Abteilungen, aber nicht alle Abteilungen haben in jedem Projekt etwas zu tun.

Nun möchte ich, dass die Abteilungen wie im Beispiel (Spalten E bis K) stehen, so dass ich im Endeffekt jeweils pro Projekt eine Zeile mit den Terminen der Abteilungen habe, um dann diverse Berechnungen starten zu können.

Lösen wollte ich das mit Index und Vergleich und einer Filterspalte (Spalte L), habe hier aber das Problem, dass sich der Bereich für die Formel Index und Vergleich bei jedem Projektwechsel (Spalte A) flexibel anpassen müsste.

Habe ich überhaupt den richtigen Ansatz gewählt, oder gibt es andere Möglichkeiten, dieses Problem zu lösen?

Ich hoffe, ich habe mich verständlich ausgedrückt, und würde mich sehr über Hilfe freuen.

https://www.herber.de/bbs/user/97157.xlsx

Viele Grüße und einen schönen Sonntag,
Michael

  

Betrifft: AW: Transponieren mit Index und Vergleich von: Hajo_Zi
Geschrieben am: 19.04.2015 15:51:39

Hallo Michael,


Tabelle1

 DEFGHIJK
2 Abteilung 1Abteilung 2Abteilung 3Abteilung 4Abteilung 5Abteilung 6Abteilung 7
380002.01.1511.03.0205.04.1514.01.1525.01.1502.03.15
480120.12.1402.01.1511.01.1525.01.1502.03.15
580205.04.1511.01.1514.01.1525.01.1502.03.15
680308.04.15

verwendete Formeln
Zelle Formel Bereich N/A
E3:K6=SUMMENPRODUKT(($A$3:$A$24=$D3)*($B$3:$B$24=E$2)*C3:C24)  

Zahlenformate
Zelle Format Wert
E3 'TT.MM.JJ;; 42006
F3 'TT.MM.JJ;; 801
G3 'TT.MM.JJ;; 42099
H3 'TT.MM.JJ;; 0
I3 'TT.MM.JJ;; 42018
J3 'TT.MM.JJ;; 42029
K3 'TT.MM.JJ;; 42065
E4 'TT.MM.JJ;; 41993
F4 'TT.MM.JJ;; 0
G4 'TT.MM.JJ;; 42006
H4 'TT.MM.JJ;; 42015
I4 'TT.MM.JJ;; 0
J4 'TT.MM.JJ;; 42029
K4 'TT.MM.JJ;; 42065
E5 'TT.MM.JJ;; 42099
F5 'TT.MM.JJ;; 0
G5 'TT.MM.JJ;; 0
H5 'TT.MM.JJ;; 42015
I5 'TT.MM.JJ;; 42018
J5 'TT.MM.JJ;; 42029
K5 'TT.MM.JJ;; 42065
E6 'TT.MM.JJ;; 42102
F6 'TT.MM.JJ;; 0
G6 'TT.MM.JJ;; 0
H6 'TT.MM.JJ;; 0
I6 'TT.MM.JJ;; 0
J6 'TT.MM.JJ;; 0
K6 'TT.MM.JJ;; 0
Zellen mit Format Standard werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.26 einschl. 64 Bit



beachte Zahlenformat.
GrußformelHomepage


  

Betrifft: AW: Transponieren mit Index und Vergleich von: michael k
Geschrieben am: 19.04.2015 16:10:06

Hallo Hajo,

wow, vielen Dank für die schnelle Antwort.

Leider stimmen die Ergebnisse nicht, z.B. müsste bei Abteilung 2 im Projekt 800 der 11.01.2015 stehen.

Viele Grüße
Michael


  

Betrifft: AW: Transponieren mit Index und Vergleich von: Hajo_Zi
Geschrieben am: 19.04.2015 16:17:41

Hallo Michael,

das war noch ein Fehler in der Formel.

Tabelle1

 DEFGHIJK
2 Abteilung 1Abteilung 2Abteilung 3Abteilung 4Abteilung 5Abteilung 6Abteilung 7
380002.01.1511.01.1514.01.1525.01.1502.03.1505.03.1501.04.15
480131.12.1420.12.1424.01.1526.03.1527.03.15
580207.01.1508.01.1505.04.1506.04.1514.04.1515.04.15
680301.04.1504.04.1507.04.1508.04.15

verwendete Formeln
Zelle Formel Bereich N/A
E3:K6=SUMMENPRODUKT(($A$3:$A$24=$D3)*($B$3:$B$24=E$2)*$C$3:$C$24)  

Zahlenformate
Zelle Format Wert
E3 'TT.MM.JJ;; 42006
F3 'TT.MM.JJ;; 42015
G3 'TT.MM.JJ;; 42018
H3 'TT.MM.JJ;; 42029
I3 'TT.MM.JJ;; 42065
J3 'TT.MM.JJ;; 42068
K3 'TT.MM.JJ;; 42095
E4 'TT.MM.JJ;; 42004
F4 'TT.MM.JJ;; 0
G4 'TT.MM.JJ;; 41993
H4 'TT.MM.JJ;; 42028
I4 'TT.MM.JJ;; 0
J4 'TT.MM.JJ;; 42089
K4 'TT.MM.JJ;; 42090
E5 'TT.MM.JJ;; 42011
F5 'TT.MM.JJ;; 42012
G5 'TT.MM.JJ;; 0
H5 'TT.MM.JJ;; 42099
I5 'TT.MM.JJ;; 42100
J5 'TT.MM.JJ;; 42108
K5 'TT.MM.JJ;; 42109
E6 'TT.MM.JJ;; 42095
F6 'TT.MM.JJ;; 0
G6 'TT.MM.JJ;; 42098
H6 'TT.MM.JJ;; 0
I6 'TT.MM.JJ;; 0
J6 'TT.MM.JJ;; 42101
K6 'TT.MM.JJ;; 42102
Zellen mit Format Standard werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.26 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: Transponieren mit Index und Vergleich von: michael k
Geschrieben am: 19.04.2015 16:33:33

Hallo Hajo,

das ist es!!!!

Ganz herzlichen Dank, Du hast meinen Sonntag gerettet :-)

Viele Grüße
Michael


 

Beiträge aus den Excel-Beispielen zum Thema "Transponieren mit Index und Vergleich"