Werte abgleichen und zusammen neu ausgeben

Bild

Betrifft: Werte abgleichen und zusammen neu ausgeben
von: Ralf
Geschrieben am: 21.05.2015 09:37:19

Guten Morgen,
neuer Tag, neues Glück.
Nachdem ich gestern mit Hilfe von Nepumuk eine VBA Lösung für meine Zeiterfassung gefunden habe, kümmere ich mich nun um die Auswertung.
In der anliegenden Tabelle werden automatisiert Einträge für "Kommt" und "Geht" Zeiten, versehen mit Name und Datum des jew. Mitarbeiters eingetragen.
Im Tabellenblatt "Bereinigt" möchte ich die Daten irgendwie so zusammenführen, dass anschließend die jeweilige "Kommt" und "Geht" Uhrzeit nebeneinander steht, also nur noch eine Zeile je Tag und Mitarbeiter füllt.
Beispiel:
Mitarbeiter 1 - 08:00:00 - 16:00:00 - 20.05.2015
Wir kann ich das umsetzen? Mir fehlt die passende Idee.
Danke vorab!
https://www.herber.de/bbs/user/97754.xlsx

Bild

Betrifft: AW: Werte abgleichen und zusammen neu ausgeben
von: UweD
Geschrieben am: 21.05.2015 13:01:04
Hallo
mit Hilfe von http://www.excelformeln.de/formeln.html?welcher=194
Formeln nach unten kopieren...

Bereinigt

 ABCD
1NameKommtGehtDatum
2Mitarbeiter 108:00:0016:00:0020.05.15
3Mitarbeiter 206:00:0014:00:0020.05.15
4    
5    
6    
7    
8    
9    
10    
11    
12    

verwendete Formeln
Zelle Formel Bereich N/A
A2{=WENNFEHLER(INDEX(Auswertung!A:A;VERGLEICH(1;(ZÄHLENWENN(A$1:A1;Auswertung!A$1:A$99)=0)*(Auswertung!A$1:A$99<>"");0));"")}$A$2 
B2=WENNFEHLER(SVERWEIS($A2;Auswertung!$A:$D;2;0);"")  
C2=WENNFEHLER(SVERWEIS($A2;Auswertung!$A:$D;3;1);"")  
D2=WENNFEHLER(SVERWEIS($A2;Auswertung!$A:$D;4;0);"")  
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


Rückmeldung wäre nett.
Gruß UweD

Bild

Betrifft: AW: Werte abgleichen und zusammen neu ausgeben
von: Ralf
Geschrieben am: 21.05.2015 13:08:14
Hallo UweD,
funktioniert auf Anhieb! Super!!!
Danke!
Gruß
Ralf

Bild

Betrifft: AW: Werte abgleichen und zusammen neu ausgeben
von: Ralf
Geschrieben am: 21.05.2015 13:14:13
Ups, zu früh gefreut.
Wenn ich jetzt Mitarbeiter1 am selben Tag noch mal kommen und gehen lasse, erscheint das in der Auswertung nicht. Auch Folgetage (21.05.2015) werden nicht eingetragen. Woran kann das liegen?
Gruß
Ralf

Bild

Betrifft: AW: offen für alle
von: UweD
Geschrieben am: 21.05.2015 13:28:36


Bild

Betrifft: AW: offen für alle
von: Ralf
Geschrieben am: 21.05.2015 15:10:03
Nur mal gesponnen:
Wenn ich eine Spalte im Tabellenblatt "Auswertung" hinzufügen würde, die jedem Eintrag eine eindeutige ID (z.B. fortlaufende Nummer) vergeben würde und man die Formel(n) im Tabellenblatt "Bereinigt" entsprechend anpassen würde, käme man dann weiter?

Bild

Betrifft: probiers doch aus,dann siehst Du es... owT
von: robert
Geschrieben am: 21.05.2015 15:27:32


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Werte abgleichen und zusammen neu ausgeben"