Herbers Excel-Forum - das Archiv

wenn CheckBox aktiviert ist

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: wenn CheckBox aktiviert ist
von: jmmypikfein

Geschrieben am: 29.12.2006 11:03:08
Guten Morgen zusammen,
ich bitte euch um Hilfe!
ich möchte wenn CheckBox aktiviert ist(Steuerelement-Toolbox),die Summe der Zellen C71:AG71 automatisch ausgerechnet werden.Wenn nicht aktiviert ist soll nur einer null in der zelle AH71 stehen.Ist das möglich?
(ich bin Anfänger)
Gruß
Ahmadian
Bild

Betrifft: AW: wenn CheckBox aktiviert ist
von: Luschi

Geschrieben am: 29.12.2006 11:43:55
Hallo Ahmadian,
verknüpfe die Checkbox mit einer Zelle (z.B: H4 in Eigenschaft "LinkedCell")
dann lautet die Formel in AH71
=WENN(H4;SUMME(C71:AG71);0)
Ist die Checkbox angeklickt, dann steht in H4 der Wert WAHR und die Summenformel wird berechnet, ansonsten FALSCH und in AH71 steht der Wert 0.
Gruß von Luschi
aus klein-Paris
Bild

Betrifft: AW: wenn CheckBox aktiviert ist
von: jmmypikfein
Geschrieben am: 29.12.2006 12:03:20
Hallo Luschi,
Vielen Dank für die schnelle Antwort. Ich habe ausprobiert, leider funktioniert nicht.
Siehe Anlage
https://www.herber.de/bbs/user/39240.xls
Gruß
Ahmadian
Bild

Betrifft: AW: wenn CheckBox aktiviert ist
von: lupo
Geschrieben am: 29.12.2006 13:49:19
Es fehlte noch die Bedingung, so sollte es flunzen:
=WENN(A2=WAHR;SUMME(A1:H1);0)
MfG und nen guten Rutsch, Lupo
Bild

Betrifft: AW: wenn CheckBox aktiviert ist
von: jimmypikfein
Geschrieben am: 29.12.2006 15:59:00
Hallo Lupo,
vielen Dank für deine Hilfe!
Gruß
Ahmadian
Bild

Betrifft: AW: wenn CheckBox aktiviert ist
von: Luschi
Geschrieben am: 29.12.2006 14:52:03
Hallo Ahmadian,
die Zahlen für die Summe stehen in Zeile 1 und nicht in Zeile2; deshalb:
=WENN(A2;SUMME(B1:H1);0)   statt   =WENN(A2;SUMME(A2:H2);0)
Gruß von Luschi
aus klein-Paris
Bild

Betrifft: AW: wenn CheckBox aktiviert ist
von: jimmypikfein
Geschrieben am: 29.12.2006 16:00:41
Hallo Luschi,
ich danke dir für deine Hilfe!
Gruß
Ahmadian
 Bild
Excel-Beispiele zum Thema "wenn CheckBox aktiviert ist"
Zustand von Tabellenblatt-Checkboxes ermitteln Summenbildung bei Checkboxaktivierung
Alle CheckBoxes einer UserForm ansprechen Beim Aktivieren einer CheckBox Häkchen in Zelle eintragen
Passwort vergeben und bei CheckBox-Aktivität abfragen CheckBoxes in UserForms in eine Schleife einbinden
Anzahl von CheckBoxes in einer UserForm ermitteln Werte von CheckBoxes in einer UserForm abfragen
ComboBox in Abhängigkeit von einer CheckBox anzeigen CheckBoxes in einer Tabelle über Zelleingaben steuern