Herbers Excel-Forum - das Archiv

Wenn, dann (zählen) -ohne VBA-

Bild

Betrifft: Wenn, dann (zählen) -ohne VBA-
von: Wolfgang

Geschrieben am: 08.01.2007 08:42:42
Hallo,
ich würde gerne diverse Zählungen anstellen - immer in Abhänigkeit von Spalte H zu Spalte D; In Spalte H befinden sich unter anderem zwei entscheidende Merkmale AA oder AB; In Spalte D die Anrede "Frau" oder "Herr". Welche Abfrage/Formel nehme ich da, um z.B. die Anzahl "Frau" in Spalte D zu ermitteln, wenn in der jeweiligen Zeile in Spalte H "***AB***" steht (entscheidend wie gesagt ist dabei als Kriterium AB oder AA); Ich habe schon verschiedene Formeln versucht, komme aber auf keinen grünen Zweig.
Danke schon jetzt allen für die Rückantwort.
Gruß - Wolfgang
Bild

Betrifft: AW: Wenn, dann (zählen) -ohne VBA-
von: MRP
Geschrieben am: 08.01.2007 08:46:55
Hallo Wolfgang,
per Formel müsste es mit der Funktion =SUMMENPRODUKT() gehen. Aber ich würde Vorschlagen einen Pivottabellen-Bericht zu machen.
Ciao
Manuele Rocco Parrino
Bild

Betrifft: AW: Wenn, dann (zählen) -ohne VBA-
von: jockel
Geschrieben am: 08.01.2007 09:30:11
hi Wolfgang, wie wärs mit 'ner beispieldatei..? cu jörg
Bild

Betrifft: AW: Wenn, dann (zählen) -ohne VBA-
von: heinzel

Geschrieben am: 08.01.2007 12:48:17
Hallo Wofgang
Wenn nur anzahl Frau oder Herr würde es auch so reichen?
Tabelle2

 ABCDEFGHI
1AnredeVorname NameStrassePlzOrtBedingung 1Frau3
2FrauTester1Tester1Tester19912Irgendwo 1Bedingung 2Herr5
3HerrTester2Tester2Tester29914Irgendwo 2   
4HerrTester3Tester3Tester39916Irgendwo 3   
5FrauTester4Tester4Tester49918Irgendwo 4   
6HerrTester5Tester5Tester59920Irgendwo 5   
7HerrTester6Tester6Tester69922Irgendwo 6   
8HerrTester7Tester7Tester79924Irgendwo 7   
9FrauTester8Tester8Tester89926Irgendwo 8   

Formeln der Tabelle
ZelleFormel
I1=SUMMENPRODUKT((A2:A9="Frau")*(H1="Frau"))
I2=SUMMENPRODUKT((A2:A9="Herr")*(H2="Herr"))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruss
heinzel
Bild

Betrifft: AW: Wenn, dann (zählen) -ohne VBA-
von: jockel
Geschrieben am: 08.01.2007 13:25:03
hi heinzel(-männchen?), bei deinem vorschlag reicht: =ZÄHLENWENN($A$2:$A$9;H1)
cu jörg
Bild

Betrifft: Danke Allen!!!
von: Wolfgang

Geschrieben am: 08.01.2007 19:19:42
Hallo,
kann leider erst jetzt antworten (im Büro funktionierte Internet auf einmal nicht mehr); Danke für die Rückmeldungen; Ich habe die Anregungen und Hinweise gerade aufgegriffen und umgesetzt. Auf die Idee mit Pivot war ich dabei noch gar nicht gekommen, habe sie somit nun auch umgesetzt und es funktioniert wunderbar. Herzlichen Dank somit noch einmal allen für die Rückmeldungen und weiterhin alles Gute.
Gruß - Wolfgang
 Bild