Microsoft Excel

Herbers Excel/VBA-Archiv

Rechnen mit Datum | Herbers Excel-Forum


Betrifft: Rechnen mit Datum von: Rosi
Geschrieben am: 18.01.2010 14:02:05

Hallo Forum,

ich habe eine Tabelle in die ich laufende Aufträge eingebe,die mit einer einmaligen Auftragsnummer gezeichnet werden (10 001 für den ersten Auftrag in 2010).

Abgeleitet vom aktuellen Datum in K2 erstellte mir die Formel in G3 stets die nächste Auftragsnummer und ich konnte in D2 die zuletzt vergebene erkennen.

Dies funktionierte schon einige Jahre,aber nun ab 2010 klappt es nicht mehr.Scheinbar müsste an der Formel etwas verändert werden?

Wer kennt sich damit aus und kann mir helfen?

https://www.herber.de/bbs/user/67284.xls

Gruß Rosi

  

Betrifft: AW: Rechnen mit Datum von: Luschi
Geschrieben am: 18.01.2010 14:29:53

Hallo Rosi,

da die letzte zwei Stellen von 2010 schon 2-stellig sind, lautet die Formel so:

=WENN(JAHR(K2)-2000=1*LINKS(D2;2);D2+1;1000*(JAHR(K2)-2000)+1)

Gruß von Luschi
aus klein-Paris


  

Betrifft: AW: Rechnen mit Datum von: Rosi
Geschrieben am: 19.01.2010 05:58:20

Hallo Luschi,

sorry,war gestern nicht mehr online.
Möchte mich herzlich bedanken,so geht es.

Gruß Rosi


Beiträge aus den Excel-Beispielen zum Thema "Rechnen mit Datum"