Rechnen mit Datum

Bild

Betrifft: Rechnen mit Datum
von: Stefan Resch
Geschrieben am: 06.05.2015 10:44:13

Hallo Expertenteam!
Ich arbeite mit einer Tabelle, die die Stunden unserer Arbeiter ausrechnen soll. Dabei steht der Arbeitsbeginn in Spalte A, Arbeitsende in Spalte B, Mittagspause in Spalte C. geleistete Stunden in Spalte D und Überstunden in Spalte E.
Die Funktion für Spalte D sollte folgendermaßen funktionieren: Arbeitsende-Arbeitsbeginn-Mittagspause=geleistete Stunden. Sobald mehr als 8 Stunden geleistet wurden soll in der Überstunden-Spalte die Differenz der geleisteten Stunden und dem Basiswert 8 stehen. Ich hoffe ich habe mich bis jetz einigermaßen klar ausgedrückt.
Mein Problem ist jedoch, dass Beginn und Ende im Format Uhrzeit angezeigt werden sollen, der Rest aber in Dezimalzahlen.
Bsp:
Beginn = 07:00
Ende = 17:00
Pause = 0,5 Stunden
daraus folgt eine Leistung von 9,5 Stunden, davon 1,5 Überstunden.
Wie könnte da die Formel für Stunden und Überstunden aussehen.
Danke im Voraus.
MFG

Bild

Betrifft: AW: Rechnen mit Datum
von: SF
Geschrieben am: 06.05.2015 10:47:37
Hola,
für D:

=(B1-A1)*24-C1
für E:
=WENN(D1>8;D1-8;"")
Gruß,
steve1da

Bild

Betrifft: AW: Rechnen mit Datum
von: Stefan Resch
Geschrieben am: 06.05.2015 11:48:57
Danke! funktioniert perfekt!!!

Bild

Betrifft: AW: Rechnen mit Datum
von: Stefan Resch
Geschrieben am: 06.05.2015 11:49:00
Danke! funktioniert perfekt!!!

Bild

Betrifft: AW: Rechnen mit Datum
von: Wilfried Höttl
Geschrieben am: 06.05.2015 11:01:52
Hallo!
Meinst du es so?
Tabelle6

 ABCDEFGHI
20kommengehenPauseSollIstPlusstundenMinusstundenDezimal +/-nicht rechnenbar
2107:0013:0000:3008:0006:00 02:30-2,50-02:30
2209:0514:1200:3008:0005:07 03:23-3,38-03:23
2308:3016:0000:3008:0007:30 01:00-1,00-01:00
2407:1016:0000:3006:0008:5002:20 2,33 02:20
2519:0002:0000:3006:0007:0000:30 0,50 00:30
26   36:0034:2702:5006:53-4,05-04:03
27Summenzeil.[hh]:mm       
28     hh:mm;;hh:mm;;  

Formeln der Tabelle
ZelleFormel
E21=REST(B21-A21;1)
F21=WENN(D21<E21;ABS(E21-D21-C21); 0)
G21=WENN(D21>E21;ABS(D21-E21+C21); 0)
H21=(E21-D21-C21)*24
I21=WENN(E21<D21;"-";" ")&TEXT(ABS(E21-D21-C21); "[hh]:mm")
I26{=WENN(SUMMENPRODUKT((TEIL(I21:I25;2;99))*WENN(LINKS(I21:I25)="-";-1;1))<=0;"-";" ")&TEXT(ABS(SUMMENPRODUKT((TEIL(I21:I25;2;99))*WENN(LINKS(I21:I25)="-";-1;1))); "[hh]:mm")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Wilfried

Bild

Betrifft: AW: Rechnen mit Datum
von: Stefan Resch
Geschrieben am: 06.05.2015 11:21:04
Hallo Wilfried!
So sieht das Formular aus.
https://www.herber.de/bbs/user/97492.xlsx
Plus- Minusstunden sollen in eine Spalte dargestellt werden, dh wenn weniger als 8 stunden gearbeitet wurde ein negativer Wert und wenn mehr als 8 stunden ein psoitiver Wert.
kommen und gehen wie in deiner Tabelle als Uhrzeit. Die Pause und die Ist-Stunden jedoch im Dezimalformat, also nicht 00:30 sondern 0,5 Stunden.
Die Spalte Soll gibt es nicht, in den Übertunden wird soll von ist abgezogen und somit die Überstunden (ob positiv oder negativ) berechnet.

Bild

Betrifft: AW: Rechnen mit Datum
von: SF
Geschrieben am: 06.05.2015 11:25:17
Hola,
und warum probierst du nicht einfach mal unserer Vorschläge aus?
Gruß,
steve1da

Bild

Betrifft: AW: Rechnen mit Datum
von: Stefan Resch
Geschrieben am: 06.05.2015 11:57:11
Sorry Steve!
Hab zuerst nur den Beitrag von Wilfried gesehen.und gleich darauf geantwortet. Deine Lösung habe ich erst später gesehen und ausprobiert, danke nochmals!
MFG

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Rechnen mit Datum"