Live-Forum - Die aktuellen Beiträge
Datum
Titel
17.06.2024 19:56:24
17.06.2024 19:39:46
Anzeige
Archiv - Navigation
1656to1660
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zelle runterziehen mit 2 Zellen Platz

Zelle runterziehen mit 2 Zellen Platz
21.11.2018 15:02:45
Christian
Moin alle zusammen,
mir wurde hier vor einigen Tagen bei einer Formel geholfen mit der ich Datumswerte runterziehen kann, jedoch mit einer Zelle Platz zwischen zwei Datumswerten.
Jetzt wollte ich die Formel so anpassen, das ich nicht nur eine Zelle Platz habe, sondern Zwei Zellen.
Also nicht nur von A2 (29.10.2018) bis A4(30.10.2018) sondern von A2 bis A5
Wie kann ich die Formel so anpassen? Einfach die 2 in eine 3 austauschen funktioniert leider nicht
=WENN(REST(ZEILE(A3);2);INDEX(Werte!A:A;ZEILE(Werte!A6)/2);"")
Vielen Dank und beste Grüße
Christian

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zelle runterziehen mit 2 Zellen Platz
21.11.2018 15:19:16
Daniel
Hi
da muss man schon ein bisschen mehr rechnen und in die Berechnung sollten nicht nur die Abstände eingehen, sondern auch die Startzeilen:
außedem funktioniert hier die Vereinfachung der WENN-Funktion (0 = falsch, alle anderen Zahlen = Wahr) nicht mehr:
in A2:

=WENN(REST(ZEILE(A2);3)=2;INDEX(Werte!A:A;Ganzzahl((ZEILE(A1)-1)/3)+x;"")

wobei x die Nummer der ersten Zeile, die gelesen werden soll, sein muss.
Gruß Daniel
AW: Zelle runterziehen mit 2 Zellen Platz
21.11.2018 15:52:01
Christian
Dann bekomme ich leider eine Fehlermeldung
In der Tabelle Werte stehen die Datumswerte beginnend in der Zelle A3, A4, A5
Und die sollen in eine andere Tabelle in der Form A2, A5 übertragen werden. Und mit der Formel bekomme ich leider nur #Wert
=WENN(REST(ZEILE(A2);3)=2;INDEX(Werte!A:A;GANZZAHL((ZEILE(A1)-1)/3)+Werte!A3;""))
Trotzdem danke für deinen Support
Anzeige
AW: Zelle runterziehen mit 2 Zellen Platz
21.11.2018 16:16:09
Daniel
Hi
das lieg daran, dass du den Satz "wobei x die Nummer der ersten Zeile, die gelesen werden soll, sein muss" nicht richt verstanden hast.
gemeint war, wenn der erste zu lesende Wert in Zeile drei steht:
=WENN(REST(ZEILE(A2);3)=2;INDEX(Werte!A:A;GANZZAHL((ZEILE(A1)-1)/3)+3);"")
Gruß Daniel
Vielen Dank Daniel
21.11.2018 16:27:59
Christian
Ach so^^ oha vielen Dank, das ist ja Wahnsinn. Mit der Formelstruktur habe ich es ab jetzt selber in der Hand, wie hoch der Abstand sein soll. Die Formel werde ich mit Sicherheit noch öfters verwenden.
AW: Zelle runterziehen mit 2 Zellen Platz
21.11.2018 15:49:42
Guenther
Hallo Christian
gib in A3 ein:
=wenn(rest(zeile(A1);3)=0;max(A$2:A2)+1;"")
Gruß
Günther
Anzeige
AW: Zelle runterziehen mit 2 Zellen Platz
21.11.2018 16:08:18
Christian
Der Zeilenabstand stimmt, jedoch bekomme ich nur den 26.12.2018 angezeigt. Also den letzten Tag in meiner Tabelle Werte plus 1. Aber wir nähern uns langsam an :) Vielen Dank
21.11.2018
22.11.2018
23.11.2018
26.11.2018
27.11.2018
28.11.2018
29.11.2018
30.11.2018
03.12.2018
04.12.2018
05.12.2018
06.12.2018
07.12.2018
10.12.2018
11.12.2018
12.12.2018
13.12.2018
14.12.2018
17.12.2018
18.12.2018
19.12.2018
20.12.2018
21.12.2018
24.12.2018
25.12.2018

183 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige