Excel 2013, Werte aus variablen Intervallen ziehen

Bild

Betrifft: Excel 2013, Werte aus variablen Intervallen ziehen
von: Tab
Geschrieben am: 15.10.2015 18:50:04

Hallo zusammen,
ich möchte hier um eure Hilfe bitten, da ich leider auch nach Stunden Googlerecherche nicht zur Lösung komme.
Folgende Situation:
Ich habe in Spalte A ("Stufe") unregelmäßige Intervalle. Die Reihenfolge ist variabel nur die 0 begrenzt diese immer wieder. Ich möchte nun das anhand der Daten aus Spalte A ("Stufe") eine neue Spalte erzeugen in der die Maximalwerte (da diese auch mehrfach auftreten) mit 0 markiert werden und die restlichen mit 1.
Ich stelle es mir ungefähr so vor:
Stufe Ausgabe
0 0
1 0
2 1
0 0
1 0
2 0
2 0
3 1
3 1
0 0
1 0
2 1
2 1
0 0
https://www.herber.de/bbs/user/100818.xlsx
Danke im voraus für die Hilfe!

Bild

Betrifft: mit INDIREKT und VERGLEICH
von: WF
Geschrieben am: 15.10.2015 20:41:31
Hi,
in B1:
=(A1=MAX(INDIREKT("a"&ZEILE(A1)&":a"&ZEILE(A1)+VERGLEICH(0;A2:A$99;0))))*1
runterkopieren
Mit Deiner hochgeladenen Datei kann ich null anfangen ?
WF

Bild

Betrifft: AW: mit INDIREKT und VERGLEICH
von: Josef B
Geschrieben am: 15.10.2015 22:26:06
Hallo
Hier noch eine andere Variante
In B2: =MAX((A2=A3)*B3;A3<A2)
Gruss Sepp

Bild

Betrifft: OK - geht nur beim letzten Maximum in die Hose
von: WF
Geschrieben am: 15.10.2015 22:41:53
.

Bild

Betrifft: AW: OK - geht nur beim letzten Maximum in die Hose
von: Tab
Geschrieben am: 15.10.2015 22:53:48
Erstmal vielen Dank für die schnelle Hilfe euch beiden!
Die erste Lösung hat gleich wie gewollt funktioniert, also danke nochmal an WF.
Wäre nett wenn du mir kurz die verwendete Funktion erklären könntest (eder ein Link setzten, wo ich es nachlesen kann), da ich nur Anfänger bin und es gern verstehen würde.
Danke nochmal!

Bild

Betrifft: AW: auch wenn Du es als gelöst betrachtest, ...
von: ... neopa C
Geschrieben am: 16.10.2015 08:05:05
Hallo,
... das bisherige Lösungsangebot berücksichtigt lediglich die jeweiligen MAX-Werte richtig, wenn diese im Intervall niemals abfallende Stufen-Werte aufweisen. Ist das der Fall?
Wenn ja, würde ich folgende INDEX()-Variante vorziehen:
=WENN(A2=0;0;(MAX(INDEX(A:A;ZEILE()):INDEX(A:A;ZEILE()+VERGLEICH(;A3:A99;)))=A2)*1)
Anderenfalls (bei möglicherweise abfallenden Stufenwerten) z.B. so:
=WENN(A2=0;0;(MAX(INDEX(A:A;VERWEIS(9;1/(A$1:A2=0);ZEILE(A:A))):INDEX(A:A;VERGLEICH(;A2:A99;)+ZEILE() -1))=A2)*1)
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel 2013, Werte aus variablen Intervallen ziehen"