Microsoft Excel

Herbers Excel/VBA-Archiv

jede zweite Zeile Kopieren

Betrifft: jede zweite Zeile Kopieren von: Ines
Geschrieben am: 02.09.2004 14:07:23

Ich möchte ohne VBA-Code aus der einen Spalte, nur jede zweite Zelle in die andere Spalte kopieren.
Wie geht denn das - ich steh auf der Leitung!

Liebe Grüße
ines

  


Betrifft: AW: jede zweite Zeile Kopieren von: Dr.
Geschrieben am: 02.09.2004 14:09:50

Prüfe doch über =Zelle() ab, ob die jeweilige Zeile gerade oder ungerade ist und kopiere dann entweder den Wert oder nicht.


  


Betrifft: AW: jede zweite Zeile Kopieren von: ines
Geschrieben am: 02.09.2004 14:19:34

Ok, das hab ich mal gemacht - war ein guter Ansatz!
Nun möchte ich aber in der zweien Spalte, in die nur jeder 2.Wert der ersten Spalte kopiert werden soll, keine Leerzellen dazwischen haben.
Wie mach ich das? Ist das mit diesem Ansatz möglich?

LG
Ines


  


Betrifft: AW: jede zweite Zeile Kopieren von: Dr.
Geschrieben am: 02.09.2004 14:20:51

Boris wird mich zwar auslachen und lockerflockich ne Formel aus dem Ärmel schütteln, aber ich glaube, hier kommst du um VBA nicht herum.


  


Betrifft: AW: jede zweite Zeile Kopieren von: EtoPHG
Geschrieben am: 02.09.2004 14:23:50

Hallo Dr.

Bin zwar nicht Boris, aber kann trotzdem lachen ;-)

Siehe meine Formel weiter unten.

Hansueli


  


Betrifft: AW: jede zweite Zeile Kopieren von: PeterW
Geschrieben am: 02.09.2004 14:12:46

Hallo Ines,

das könnte so gehen:
=WENN(REST(A1;2)=0;A1;"") wobei in Spalte A die zu kopierenden Werte stehen.

Gruß
Peter


  


Betrifft: Korrektur von: PeterW
Geschrieben am: 02.09.2004 14:15:21

Man sollte auch sowas testen. Richtig wäre natürlich:
=WENN(REST(ZEILE();2)=0;A1;"")

Gruß
Peter


  


Betrifft: AW: jede zweite Zeile Kopieren von: EtoPHG
Geschrieben am: 02.09.2004 14:15:57

Hallo Ines,

Die Formel für die Spalte neben der zu kopierenden lautet:

=INDIREKT(ADRESSE(ZEILE()+(ZEILE()-1);SPALTE()-1))

Gruss Hansueli


  


Betrifft: AW: jede zweite Zeile Kopieren von: Ines
Geschrieben am: 02.09.2004 14:25:42

Hmmm, könntest du die Klammern bitte noch mit Bezügen füllen, damit ich die Zusammenhänge erkennen kann?

Wär ganz lieb!
Danke


  


Betrifft: AW: jede zweite Zeile Kopieren von: EtoPHG
Geschrieben am: 02.09.2004 14:31:01

Ines,

Du brauchst keine Bezüge, das macht die Formel automatisch
allerdings müsstest du das -1 durch den Abstand zwischen den Spalten ersetzen.
D.h. z.B. Spalte 1 (A) nach Spalte 2 (B) = -1
Spalte 5 (E) nach Spalte 8 (H) = -3
Spalte 9 (I) nach Spalte 3 (C) = +6

Die Nummer entspricht der Spalten von A... nach rechts gezöhlt.

Gruss Hansueli


  


Betrifft: AW: jede zweite Zeile Kopieren von: EtoPHG
Geschrieben am: 02.09.2004 14:37:42

Nachtrag zu oben,
Natürlich nur das -1 bei SPALTE()-1 nicht das hinter ZEILE() !!
Das erste macht nur den offset um jede 2.te zeile !!
Verstanden ??

Gruss Hansueli


  


Betrifft: AW: jede zweite Zeile Kopieren von: Ines
Geschrieben am: 02.09.2004 14:40:47

Jawohl! Juhuuu!!
Ich danke dir :)


  


Betrifft: Einfacher wäre... von: Boris
Geschrieben am: 02.09.2004 14:43:38

Hi Hansueli,

=INDIREKT("A"&ZEILE(A1)*2-1)

und runterkopieren.
Den ganzen Schnickschnack mit SPALTE()-1 oder +6 oder... kannst du dir dadurch ersparen, indem die den Funktionen ZEILE und SPALTE einen Zellbezug mitgibst - dann ist die Startzeile- und Spalte sowie irgendein Spaltenversatz völlig wurscht.
Mein obige Formel kannst du irgendwo eintragen und runterkopieren - sie liest immer zuerst A1 aus - da ZEILE(A1) = 1

Grüße Boris


  


Betrifft: AW: Einfacher wäre... von: Dr.
Geschrieben am: 02.09.2004 14:45:23

ICH WUSSTE ES *wechlach*


  


Betrifft: ;-)) von: Boris
Geschrieben am: 02.09.2004 14:46:20

Grüße Boris


  


Betrifft: AW: Einfacher wäre... von: EtoPHG
Geschrieben am: 02.09.2004 14:53:52

Hallo Boris,

Einverstanden, wenn Du bei A1 startest.
Starte mal irgendwo in der Tabelle.

Ich hab mich nur versucht and die Specs von Ines zu halten
"..aus der einen Spalte, nur jede zweite Zelle in die andere Spalte kopieren"
hab also nicht gewusst wo die Kopiererei anfängt...

Gruss Hansueli


  


Betrifft: Bei Start in A9... von: Boris
Geschrieben am: 02.09.2004 15:04:36

Hi Hansueli,

...ist das doch auch ganz einfach:
Zeile halbieren und aufrunden (Start ab Zeile 9: 9/2=4,5 - aufgerundet 5).
=INDIREKT("A"&ZEILE(A5)*2-1)
und runterkopieren.

Ich halte das wirklich für wesentlich einfacher.

Grüße Boris


  


Betrifft: AW: Bei Start in A9... :-) von: EtoPHG
Geschrieben am: 02.09.2004 15:11:38

Hallo Boris,

Warum soll ich rechnen ( 9/2 = 4,5 aufrunden... ) wenn EXCEL es tut ??

Ich glaube die Definition von einfacher... ist eine philosophische.
Ich bin begeistert von Deinem Ansatz und gebe zu er "sieht" einfacher aus.
Ob er allerdings ...allgemeingültiger ist ??? Wäre vermutlich wieder philosophisch.

Gruss Hansueli


  


Betrifft: AW: Bei Start in A9... :-) von: Boris
Geschrieben am: 02.09.2004 15:18:54

Hi Hansueli,

wo soll man denn deine Formel =INDIREKT(ADRESSE(ZEILE()+(ZEILE()-1);SPALTE()-1)) eintragen, wenn das Ganze in A9 beginnt? ;-)

Grüße Boris


  


Betrifft: O.K. - vergiss es... von: Boris
Geschrieben am: 02.09.2004 15:20:33

...es soll dann -9 heissen - ich vergaß.

Grüße Boris


  


Betrifft: AW: O.K. - vergiss es... von: EtoPHG
Geschrieben am: 02.09.2004 15:25:39

In irgendeiner Spalte (ausser Spalte 1) in der 9ten Zeile !!!!

Gemäss 'Spezifikation... von Ines' war nur von einem Spaltenversatz, nicht von einem Zeilenversatz die Rede.

Gruss Hansueli


  


Betrifft: AW: O.K. - Let's call it a draw.... von: EtoPHG
Geschrieben am: 02.09.2004 15:38:33

Hi Boris,

OK Vergessen wir die Diskussion

Deine Formel Offset muss man rechnen Offset/2 , aufrunden
Meine Formel Offset muss man zählen 1.2.3.

Gruss und Tschüss
Hansueli


 

Beiträge aus den Excel-Beispielen zum Thema "jede zweite Zeile Kopieren"