Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

AW: Blatt automatisch neu berechnen | Herbers Excel-Forum


Betrifft: AW: Blatt automatisch neu berechnen von: RalfTh
Geschrieben am: 18.01.2010 14:20:44

Hallo und vielen Dank für die Unterstützung.
Leider haben biede Lösungen nicht den gewünschten Erfolg erzielt.

Blattindex	   Blattname	                 LetzteÄnderung

1 	            Übersicht	                 Tabelle3
2	            UC3	
3	            REOOptis2	
4	            Dreamteam	
5	            DreamteamControlle	
6	            Importdaten	
7	            Importformular	
8	            ERROR_LOG	
9	            INI	
10	            Tabelle1	
11	            Tabelle3	
Die Letzte Änderung ermittle ich in der Zelle G2 mit der Formel (Wert: Tabelle3):
=TEIL(ZELLE("Dateiname");FINDEN("]";ZELLE("Dateiname"))+1;31)
Dies dient eigentlich nur dazu, die Zelle mit einem Wert zu füllen, falls irgendwo im Workbook eine Änderung erfolgt ist. Sie ist jedoch der Trigger für die Neuberechnung der Spalte "Blattnamen":
=WENN($G$2 <> "";SheetName(E2);)


Die Funktion SheetName:
'################################################
'Namen der Tabellenblätter ermittlen
'####################################################

Public Function SheetName(Index, Optional Range As Variant)
    Dim a As Variant
    a = Sheets(Index).Name
    SheetName = a
    
End Function

Mit diesem Trigger funktioniert die automatische Aktualisierung von Funktionen. Ist zwar nicht sonderlich schön, aber es funktioniert.

Gruß
Ralf

  

Betrifft: Ich sehe 3 Lösungen und 2 Threads! von: Renee
Geschrieben am: 18.01.2010 15:57:39

Hi Ralf,

Warum ein neuer Thread ?
Was ist mit Application.Volatile ??

GreetZ Renée


Beiträge aus den Excel-Beispielen zum Thema "AW: Blatt automatisch neu berechnen"