Summe bilden bis Keyword erreicht



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Summe bilden bis Keyword erreicht
von: Thorsten
Geschrieben am: 03.07.2002 - 16:57:38

Hallo,
ich habe eine Tabelle

März-----Jan----Feb----März----April----Mai---SUMME
------------10-----10-----10------10-------10----30!!!!

wobei März in Zelle A1 mein Keyword ist bis zu dem ich eine Summe in A14 gebildet haben möchte. Wie lautet die Formel für die Summe ?

Steht in A1 also März, will ich die Summe der Jan.-März-Werte haben.

Irgendwie muss das über =SUMME(INDIREKT (VERGLEICH...) gehen.
Eine dem Problem nahekommende Lösung scheint Forum-Beitrag 021698 zu sein.

Besten Dank im voraus






nach oben   nach unten

Re: Summe bilden bis Keyword erreicht
von: Hans W. Hofmann
Geschrieben am: 03.07.2002 - 17:21:52

Hallo z.B.,

=SUMME((DATWERT("1."&A1:E1)>=DATWERT("1.März"))*(A2:E2))
Eingeben und Str+Umschalt+Eingabe
eine Arrayformel...

Gruß HW

nach oben   nach unten

Re: Summe bilden bis Keyword erreicht
von: WF
Geschrieben am: 03.07.2002 - 17:24:57

Hi Thorsten,

=SUMME(B2:INDIREKT(ADRESSE(2;VERGLEICH(A1;B1:Z1;0)+1)))

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite

nach oben   nach unten

Re: Summe bilden bis Keyword erreicht
von: Hans W. Hofmann
Geschrieben am: 03.07.2002 - 17:26:15

Hallo z.B.,

=SUMME((DATWERT("1."&A1:E1)>=DATWERT("1.März"))*(A2:E2))
Eingeben und Str+Umschalt+Eingabe
eine Arrayformel...

Gruß HW

nach oben   nach unten

Re: Summe bilden bis Keyword erreicht
von: Berai
Geschrieben am: 03.07.2002 - 17:26:50

Hallo Thorsten,

in diesem Beispiel brauchst Du in A1 nur die entsprechende Monatszahl einzugeben.


MS Excel von Berai an Thorsten
 ABCDEFGHIJ
13JanFebMrzAprMaiSumme   
2  101010101030   
3               
4FormelinG2=SUMMENPRODUKT((MONAT(B1:F1)<=A1)*B2:F2)         
5InB1:F1steht01.01.02bis101.05.02Format"MMM"  


Gruß
Rainer


nach oben   nach unten

Re: Summe bilden bis Keyword erreicht
von: Thorsten
Geschrieben am: 04.07.2002 - 08:39:20

Hallo WF,
besten Dank für Deine Lösung,

allerdings wird die Summe dann über den gesamten Bereich A1:D2 gebildet. Die Formel sollte allerdings nur die Summe der 2ten Zeile bilden. Wenn ich mehrer Zeilen habe, dann wird am Ende immer die Summe über alle Zahlen stehen.
An welcher Stelle muss ich den Bereich abändern?

nach oben   nach unten

Hat sich erledigt!
von: Thorsten
Geschrieben am: 04.07.2002 - 08:46:47

Hat sich erledigt. Besten Dank nochmal. Hier bei herber.de ist es immer wieder toll zu wissen, dass man geholfen wird ;-)

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Summe bilden bis Keyword erreicht"