Herbers Excel-Forum - das Archiv

Summe bilden incl. Fehlerzellen

Bild

Betrifft: Summe bilden incl. Fehlerzellen
von: Alexander

Geschrieben am: 04.01.2007 13:19:36
Hi,
Ich moehcte gerne eine Summe verschiedener Einzelzellen bilden, die jedoch nicht in einem zusammenhaengenden Bereich liegen. Da alle Zellen Zellreferenzen zu einem anderen Tabellenblatt sind, kann es sein, dass einige der Zellen Fehlerwerte beinhalten.
Wie kann ich nun die Summe mit einer Formel bilden? Wie gesgat sind die Zellen nicht in einer Range, also funktinoiert bei mir die Formel {=SUMME(WENN(ISTFEHLER(A1:A10);0;A1:A10))} bei mir nicht. Gerne moechte ich ohne VBA arbeiten, wenn es geht.
Anbei eine Tabelle.
https://www.herber.de/bbs/user/39366.xls
In Zelle D25 moechte ich die Summe aus D5, D10, D15, D20 darstellen.
Vielen Dank fuer Eure Hilfe,
Alexander
Bild

Betrifft: AW: Summe bilden incl. Fehlerzellen
von: EtoPHG
Geschrieben am: 04.01.2007 13:33:30
Hallo Alexander,
=WENN(ISTFEHLER(D5);0;D5)+WENN(ISTFEHLER(D10);0;D10)+WENN(ISTFEHLER(D15);0;D15)+WENN(ISTFEHLER(D20);0;D20)

Gruss Hansueli
 Bild
Excel-Beispiele zum Thema "Summe bilden incl. Fehlerzellen"
Summe bilden, wenn Kriterium Zeichenfolge Summe bilden, wenn Kriterium Zahl
Diagramm aus Daten einer Bandbreite bilden Email-Adresse aus Vorname, Name und Domain bilden
Mit InputBoxes Zeilennummern abfragen und Summe bilden Sätze nach dem Zufallsprinzip bilden
Eigene Klasse für UserForm-TextBoxes bilden Summe über dynamischen Bereich bilden