Live-Forum - Die aktuellen Beiträge
Datum
Titel
25.06.2024 22:07:02
25.06.2024 21:01:55
25.06.2024 19:21:44
Anzeige
Archiv - Navigation
1152to1156
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Name für alle Blätter, dynamisch, aber ohne...

Name für alle Blätter, dynamisch, aber ohne...
Norbert
Hallo
ich möchte für alle Tabellenblätter einer Arbeitsmappe einen Namen definieren, dynamisch, da später weiter Blätter hinzukommen. Dies ist ja mit der Formen =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT()) möglich.
Aber: Die Tabelle 1 und die Tabelle 3 sollen ausgenommen sein.
Kann mir jemand helfen?
Norbert

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Name für alle Blätter, dynamisch, aber ohne...
02.05.2010 11:51:04
Hajo_Zi
Hallo Norbert,
ich hätte vermutet mit der Formel list Du den Dateinamen und den Tabellenamen aus. Damit gibst Du der Tabele keinen Namen. Erkläre das mal genauer wie Du mit dieser Formel der Tabelle einen Nmaen gibst.

AW: Name für alle Blätter, dynamisch, aber ohne...
02.05.2010 12:06:23
{Boris}
Hi Norbert,
Du kannst damit keine Blätter ausnehmen, da eben eine Auflistung ALLER Blätter erzeugt wird.
Warum möchtest Du die beiden Blätter denn außen vor lassen?
Grüße Boris
AW: Name für alle Blätter, dynamisch, aber ohne...
02.05.2010 12:29:49
Tino
Hallo,
den Blattnamen wirst Du wohl damit nicht vergeben, oder doch.
Für eine Auflistung der Tabellen ohne die Tabelle1 u. die Tabelle3 habe ich es mal so gemacht.
 A
1Tabellen
2Tabelle2
3Tabelle4
4Tabelle5
5Tabelle6
6Tabelle7
7Tabelle8
8Tabelle9
9 
10 

Formeln der Tabelle
ZelleFormel
A2=WENN(ANZAHL2(TabName)-2>=ZEILE(A1); TEIL(INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A1))); FINDEN("]";INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A1))))+1;10^9); "")
A3=WENN(ANZAHL2(TabName)-2>=ZEILE(A2); TEIL(INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A2))); FINDEN("]";INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A2))))+1;10^9); "")
A4=WENN(ANZAHL2(TabName)-2>=ZEILE(A3); TEIL(INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A3))); FINDEN("]";INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A3))))+1;10^9); "")
A5=WENN(ANZAHL2(TabName)-2>=ZEILE(A4); TEIL(INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A4))); FINDEN("]";INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A4))))+1;10^9); "")
A6=WENN(ANZAHL2(TabName)-2>=ZEILE(A5); TEIL(INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A5))); FINDEN("]";INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A5))))+1;10^9); "")
A7=WENN(ANZAHL2(TabName)-2>=ZEILE(A6); TEIL(INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A6))); FINDEN("]";INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A6))))+1;10^9); "")
A8=WENN(ANZAHL2(TabName)-2>=ZEILE(A7); TEIL(INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A7))); FINDEN("]";INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A7))))+1;10^9); "")
A9=WENN(ANZAHL2(TabName)-2>=ZEILE(A8); TEIL(INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A8))); FINDEN("]";INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A8))))+1;10^9); "")
A10=WENN(ANZAHL2(TabName)-2>=ZEILE(A9); TEIL(INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A9))); FINDEN("]";INDEX(TabName;KKLEINSTE(IndexZeile;ZEILE(A9))))+1;10^9); "")
Namen in Formeln
ZelleNameBezieht sich auf
A2IndexZeile=WENN((ZEILE(Tabelle1!$1:$100)<>1)*(ZEILE(Tabelle1!$1:$100)<>3);ZEILE(Tabelle1!$1:$100))
A2TabName=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
A3IndexZeile=WENN((ZEILE(Tabelle1!$1:$100)<>1)*(ZEILE(Tabelle1!$1:$100)<>3);ZEILE(Tabelle1!$1:$100))
A3TabName=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
A4IndexZeile=WENN((ZEILE(Tabelle1!$1:$100)<>1)*(ZEILE(Tabelle1!$1:$100)<>3);ZEILE(Tabelle1!$1:$100))
A4TabName=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
A5IndexZeile=WENN((ZEILE(Tabelle1!$1:$100)<>1)*(ZEILE(Tabelle1!$1:$100)<>3);ZEILE(Tabelle1!$1:$100))
A5TabName=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
A6IndexZeile=WENN((ZEILE(Tabelle1!$1:$100)<>1)*(ZEILE(Tabelle1!$1:$100)<>3);ZEILE(Tabelle1!$1:$100))
A6TabName=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
A7IndexZeile=WENN((ZEILE(Tabelle1!$1:$100)<>1)*(ZEILE(Tabelle1!$1:$100)<>3);ZEILE(Tabelle1!$1:$100))
A7TabName=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
A8IndexZeile=WENN((ZEILE(Tabelle1!$1:$100)<>1)*(ZEILE(Tabelle1!$1:$100)<>3);ZEILE(Tabelle1!$1:$100))
A8TabName=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
A9IndexZeile=WENN((ZEILE(Tabelle1!$1:$100)<>1)*(ZEILE(Tabelle1!$1:$100)<>3);ZEILE(Tabelle1!$1:$100))
A9TabName=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
A10IndexZeile=WENN((ZEILE(Tabelle1!$1:$100)<>1)*(ZEILE(Tabelle1!$1:$100)<>3);ZEILE(Tabelle1!$1:$100))
A10TabName=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
Namen verstehen

Gruß Tino
Anzeige

304 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige