Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summieren über mehrere Blätter nach Suchkriterien

Summieren über mehrere Blätter nach Suchkriterien
reklov
Hallo,
die Frage ist bestimmt schon häufiger gestellt worden, aber bin leider nicht fündig geworden bzw. bin ich mir auch nicht sicher mit welcher Funktion es am elegantesten funktioniert.
Habe für jeden Monat ein Tabellenblatt wo die Umsätze jeden Wochentages aufgeführt sind. Jetzt möchte ich im Tabellenblatt Gesamt die Summe aller Umsätze über alle Monate die z.Bsp. am Montag erzielt worden sind zusammen addieren. Habe es schon versucht mit SVERWEIS und SUMMENPRODUKT, aber da ich in der Tiefe nicht ganz so fit bin brauche ich eure Hilfe.
Anbei habe ich auch eine ExcelDatei hochgeladen zur Veranschaulichung
https://www.herber.de/bbs/user/70492.xls
Gruß Reklov

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Summieren über mehrere Blätter nach Suchkriterien
08.07.2010 12:50:55
David
Hallo Reklov
ich würde dir empfehlen, im Summenblatt mehrere Zeilen für die Monate zu machen:
Gesamt
 ABCDEFGH
1  MoDiMiDoFrSaSo
2Januar240,00250,00270,00240,00300,00330,00350,00
3Februar1.100,001.100,001.100,001.100,001.100,001.100,001.100,00
4März0,000,000,000,000,000,000,00
5April0,000,000,000,000,000,000,00
6Mai0,000,000,000,000,000,000,00
7Juni0,000,000,000,000,000,000,00
8Juli0,000,000,000,000,000,000,00
9August0,000,000,000,000,000,000,00
10September0,000,000,000,000,000,000,00
11Oktober0,000,000,000,000,000,000,00
12November0,000,000,000,000,000,000,00
13Dezember0,000,000,000,000,000,000,00
14               
15Umsätze 1.340,001.350,001.370,001.340,001.400,001.430,001.450,00

verwendete Formeln
Zelle Formel
B2 =WENN(ISTFEHLER(INDIREKT($A2&"!A1"));0;SUMMEWENN(INDIREKT($A2&"!A2:AE2");B$1;INDIREKT($A2&"!A3:AE3")))
C2 =WENN(ISTFEHLER(INDIREKT($A2&"!A1"));0;SUMMEWENN(INDIREKT($A2&"!A2:AE2");C$1;INDIREKT($A2&"!A3:AE3")))
D2 =WENN(ISTFEHLER(INDIREKT($A2&"!A1"));0;SUMMEWENN(INDIREKT($A2&"!A2:AE2");D$1;INDIREKT($A2&"!A3:AE3")))
E2 =WENN(ISTFEHLER(INDIREKT($A2&"!A1"));0;SUMMEWENN(INDIREKT($A2&"!A2:AE2");E$1;INDIREKT($A2&"!A3:AE3")))
F2 =WENN(ISTFEHLER(INDIREKT($A2&"!A1"));0;SUMMEWENN(INDIREKT($A2&"!A2:AE2");F$1;INDIREKT($A2&"!A3:AE3")))
G2 =WENN(ISTFEHLER(INDIREKT($A2&"!A1"));0;SUMMEWENN(INDIREKT($A2&"!A2:AE2");G$1;INDIREKT($A2&"!A3:AE3")))
H2 =WENN(ISTFEHLER(INDIREKT($A2&"!A1"));0;SUMMEWENN(INDIREKT($A2&"!A2:AE2");H$1;INDIREKT($A2&"!A3:AE3")))
B3 =WENN(ISTFEHLER(INDIREKT($A3&"!A1"));0;SUMMEWENN(INDIREKT($A3&"!A2:AE2");B$1;INDIREKT($A3&"!A3:AE3")))
C3 =WENN(ISTFEHLER(INDIREKT($A3&"!A1"));0;SUMMEWENN(INDIREKT($A3&"!A2:AE2");C$1;INDIREKT($A3&"!A3:AE3")))
D3 =WENN(ISTFEHLER(INDIREKT($A3&"!A1"));0;SUMMEWENN(INDIREKT($A3&"!A2:AE2");D$1;INDIREKT($A3&"!A3:AE3")))
E3 =WENN(ISTFEHLER(INDIREKT($A3&"!A1"));0;SUMMEWENN(INDIREKT($A3&"!A2:AE2");E$1;INDIREKT($A3&"!A3:AE3")))
F3 =WENN(ISTFEHLER(INDIREKT($A3&"!A1"));0;SUMMEWENN(INDIREKT($A3&"!A2:AE2");F$1;INDIREKT($A3&"!A3:AE3")))
G3 =WENN(ISTFEHLER(INDIREKT($A3&"!A1"));0;SUMMEWENN(INDIREKT($A3&"!A2:AE2");G$1;INDIREKT($A3&"!A3:AE3")))
H3 =WENN(ISTFEHLER(INDIREKT($A3&"!A1"));0;SUMMEWENN(INDIREKT($A3&"!A2:AE2");H$1;INDIREKT($A3&"!A3:AE3")))
B4 =WENN(ISTFEHLER(INDIREKT($A4&"!A1"));0;SUMMEWENN(INDIREKT($A4&"!A2:AE2");B$1;INDIREKT($A4&"!A3:AE3")))
C4 =WENN(ISTFEHLER(INDIREKT($A4&"!A1"));0;SUMMEWENN(INDIREKT($A4&"!A2:AE2");C$1;INDIREKT($A4&"!A3:AE3")))
D4 =WENN(ISTFEHLER(INDIREKT($A4&"!A1"));0;SUMMEWENN(INDIREKT($A4&"!A2:AE2");D$1;INDIREKT($A4&"!A3:AE3")))
E4 =WENN(ISTFEHLER(INDIREKT($A4&"!A1"));0;SUMMEWENN(INDIREKT($A4&"!A2:AE2");E$1;INDIREKT($A4&"!A3:AE3")))
F4 =WENN(ISTFEHLER(INDIREKT($A4&"!A1"));0;SUMMEWENN(INDIREKT($A4&"!A2:AE2");F$1;INDIREKT($A4&"!A3:AE3")))
G4 =WENN(ISTFEHLER(INDIREKT($A4&"!A1"));0;SUMMEWENN(INDIREKT($A4&"!A2:AE2");G$1;INDIREKT($A4&"!A3:AE3")))
H4 =WENN(ISTFEHLER(INDIREKT($A4&"!A1"));0;SUMMEWENN(INDIREKT($A4&"!A2:AE2");H$1;INDIREKT($A4&"!A3:AE3")))
B5 =WENN(ISTFEHLER(INDIREKT($A5&"!A1"));0;SUMMEWENN(INDIREKT($A5&"!A2:AE2");B$1;INDIREKT($A5&"!A3:AE3")))
C5 =WENN(ISTFEHLER(INDIREKT($A5&"!A1"));0;SUMMEWENN(INDIREKT($A5&"!A2:AE2");C$1;INDIREKT($A5&"!A3:AE3")))
D5 =WENN(ISTFEHLER(INDIREKT($A5&"!A1"));0;SUMMEWENN(INDIREKT($A5&"!A2:AE2");D$1;INDIREKT($A5&"!A3:AE3")))
E5 =WENN(ISTFEHLER(INDIREKT($A5&"!A1"));0;SUMMEWENN(INDIREKT($A5&"!A2:AE2");E$1;INDIREKT($A5&"!A3:AE3")))
F5 =WENN(ISTFEHLER(INDIREKT($A5&"!A1"));0;SUMMEWENN(INDIREKT($A5&"!A2:AE2");F$1;INDIREKT($A5&"!A3:AE3")))
G5 =WENN(ISTFEHLER(INDIREKT($A5&"!A1"));0;SUMMEWENN(INDIREKT($A5&"!A2:AE2");G$1;INDIREKT($A5&"!A3:AE3")))
H5 =WENN(ISTFEHLER(INDIREKT($A5&"!A1"));0;SUMMEWENN(INDIREKT($A5&"!A2:AE2");H$1;INDIREKT($A5&"!A3:AE3")))
B6 =WENN(ISTFEHLER(INDIREKT($A6&"!A1"));0;SUMMEWENN(INDIREKT($A6&"!A2:AE2");B$1;INDIREKT($A6&"!A3:AE3")))
C6 =WENN(ISTFEHLER(INDIREKT($A6&"!A1"));0;SUMMEWENN(INDIREKT($A6&"!A2:AE2");C$1;INDIREKT($A6&"!A3:AE3")))
D6 =WENN(ISTFEHLER(INDIREKT($A6&"!A1"));0;SUMMEWENN(INDIREKT($A6&"!A2:AE2");D$1;INDIREKT($A6&"!A3:AE3")))
E6 =WENN(ISTFEHLER(INDIREKT($A6&"!A1"));0;SUMMEWENN(INDIREKT($A6&"!A2:AE2");E$1;INDIREKT($A6&"!A3:AE3")))
F6 =WENN(ISTFEHLER(INDIREKT($A6&"!A1"));0;SUMMEWENN(INDIREKT($A6&"!A2:AE2");F$1;INDIREKT($A6&"!A3:AE3")))
G6 =WENN(ISTFEHLER(INDIREKT($A6&"!A1"));0;SUMMEWENN(INDIREKT($A6&"!A2:AE2");G$1;INDIREKT($A6&"!A3:AE3")))
H6 =WENN(ISTFEHLER(INDIREKT($A6&"!A1"));0;SUMMEWENN(INDIREKT($A6&"!A2:AE2");H$1;INDIREKT($A6&"!A3:AE3")))
B7 =WENN(ISTFEHLER(INDIREKT($A7&"!A1"));0;SUMMEWENN(INDIREKT($A7&"!A2:AE2");B$1;INDIREKT($A7&"!A3:AE3")))
C7 =WENN(ISTFEHLER(INDIREKT($A7&"!A1"));0;SUMMEWENN(INDIREKT($A7&"!A2:AE2");C$1;INDIREKT($A7&"!A3:AE3")))
D7 =WENN(ISTFEHLER(INDIREKT($A7&"!A1"));0;SUMMEWENN(INDIREKT($A7&"!A2:AE2");D$1;INDIREKT($A7&"!A3:AE3")))
E7 =WENN(ISTFEHLER(INDIREKT($A7&"!A1"));0;SUMMEWENN(INDIREKT($A7&"!A2:AE2");E$1;INDIREKT($A7&"!A3:AE3")))
F7 =WENN(ISTFEHLER(INDIREKT($A7&"!A1"));0;SUMMEWENN(INDIREKT($A7&"!A2:AE2");F$1;INDIREKT($A7&"!A3:AE3")))
G7 =WENN(ISTFEHLER(INDIREKT($A7&"!A1"));0;SUMMEWENN(INDIREKT($A7&"!A2:AE2");G$1;INDIREKT($A7&"!A3:AE3")))
H7 =WENN(ISTFEHLER(INDIREKT($A7&"!A1"));0;SUMMEWENN(INDIREKT($A7&"!A2:AE2");H$1;INDIREKT($A7&"!A3:AE3")))
B8 =WENN(ISTFEHLER(INDIREKT($A8&"!A1"));0;SUMMEWENN(INDIREKT($A8&"!A2:AE2");B$1;INDIREKT($A8&"!A3:AE3")))
C8 =WENN(ISTFEHLER(INDIREKT($A8&"!A1"));0;SUMMEWENN(INDIREKT($A8&"!A2:AE2");C$1;INDIREKT($A8&"!A3:AE3")))
D8 =WENN(ISTFEHLER(INDIREKT($A8&"!A1"));0;SUMMEWENN(INDIREKT($A8&"!A2:AE2");D$1;INDIREKT($A8&"!A3:AE3")))
E8 =WENN(ISTFEHLER(INDIREKT($A8&"!A1"));0;SUMMEWENN(INDIREKT($A8&"!A2:AE2");E$1;INDIREKT($A8&"!A3:AE3")))
F8 =WENN(ISTFEHLER(INDIREKT($A8&"!A1"));0;SUMMEWENN(INDIREKT($A8&"!A2:AE2");F$1;INDIREKT($A8&"!A3:AE3")))
G8 =WENN(ISTFEHLER(INDIREKT($A8&"!A1"));0;SUMMEWENN(INDIREKT($A8&"!A2:AE2");G$1;INDIREKT($A8&"!A3:AE3")))
H8 =WENN(ISTFEHLER(INDIREKT($A8&"!A1"));0;SUMMEWENN(INDIREKT($A8&"!A2:AE2");H$1;INDIREKT($A8&"!A3:AE3")))
B9 =WENN(ISTFEHLER(INDIREKT($A9&"!A1"));0;SUMMEWENN(INDIREKT($A9&"!A2:AE2");B$1;INDIREKT($A9&"!A3:AE3")))
C9 =WENN(ISTFEHLER(INDIREKT($A9&"!A1"));0;SUMMEWENN(INDIREKT($A9&"!A2:AE2");C$1;INDIREKT($A9&"!A3:AE3")))
D9 =WENN(ISTFEHLER(INDIREKT($A9&"!A1"));0;SUMMEWENN(INDIREKT($A9&"!A2:AE2");D$1;INDIREKT($A9&"!A3:AE3")))
E9 =WENN(ISTFEHLER(INDIREKT($A9&"!A1"));0;SUMMEWENN(INDIREKT($A9&"!A2:AE2");E$1;INDIREKT($A9&"!A3:AE3")))
F9 =WENN(ISTFEHLER(INDIREKT($A9&"!A1"));0;SUMMEWENN(INDIREKT($A9&"!A2:AE2");F$1;INDIREKT($A9&"!A3:AE3")))
G9 =WENN(ISTFEHLER(INDIREKT($A9&"!A1"));0;SUMMEWENN(INDIREKT($A9&"!A2:AE2");G$1;INDIREKT($A9&"!A3:AE3")))
H9 =WENN(ISTFEHLER(INDIREKT($A9&"!A1"));0;SUMMEWENN(INDIREKT($A9&"!A2:AE2");H$1;INDIREKT($A9&"!A3:AE3")))
B10 =WENN(ISTFEHLER(INDIREKT($A10&"!A1"));0;SUMMEWENN(INDIREKT($A10&"!A2:AE2");B$1;INDIREKT($A10&"!A3:AE3")))
C10 =WENN(ISTFEHLER(INDIREKT($A10&"!A1"));0;SUMMEWENN(INDIREKT($A10&"!A2:AE2");C$1;INDIREKT($A10&"!A3:AE3")))
D10 =WENN(ISTFEHLER(INDIREKT($A10&"!A1"));0;SUMMEWENN(INDIREKT($A10&"!A2:AE2");D$1;INDIREKT($A10&"!A3:AE3")))
E10 =WENN(ISTFEHLER(INDIREKT($A10&"!A1"));0;SUMMEWENN(INDIREKT($A10&"!A2:AE2");E$1;INDIREKT($A10&"!A3:AE3")))
F10 =WENN(ISTFEHLER(INDIREKT($A10&"!A1"));0;SUMMEWENN(INDIREKT($A10&"!A2:AE2");F$1;INDIREKT($A10&"!A3:AE3")))
G10 =WENN(ISTFEHLER(INDIREKT($A10&"!A1"));0;SUMMEWENN(INDIREKT($A10&"!A2:AE2");G$1;INDIREKT($A10&"!A3:AE3")))
H10 =WENN(ISTFEHLER(INDIREKT($A10&"!A1"));0;SUMMEWENN(INDIREKT($A10&"!A2:AE2");H$1;INDIREKT($A10&"!A3:AE3")))
B11 =WENN(ISTFEHLER(INDIREKT($A11&"!A1"));0;SUMMEWENN(INDIREKT($A11&"!A2:AE2");B$1;INDIREKT($A11&"!A3:AE3")))
C11 =WENN(ISTFEHLER(INDIREKT($A11&"!A1"));0;SUMMEWENN(INDIREKT($A11&"!A2:AE2");C$1;INDIREKT($A11&"!A3:AE3")))
D11 =WENN(ISTFEHLER(INDIREKT($A11&"!A1"));0;SUMMEWENN(INDIREKT($A11&"!A2:AE2");D$1;INDIREKT($A11&"!A3:AE3")))
E11 =WENN(ISTFEHLER(INDIREKT($A11&"!A1"));0;SUMMEWENN(INDIREKT($A11&"!A2:AE2");E$1;INDIREKT($A11&"!A3:AE3")))
F11 =WENN(ISTFEHLER(INDIREKT($A11&"!A1"));0;SUMMEWENN(INDIREKT($A11&"!A2:AE2");F$1;INDIREKT($A11&"!A3:AE3")))
G11 =WENN(ISTFEHLER(INDIREKT($A11&"!A1"));0;SUMMEWENN(INDIREKT($A11&"!A2:AE2");G$1;INDIREKT($A11&"!A3:AE3")))
H11 =WENN(ISTFEHLER(INDIREKT($A11&"!A1"));0;SUMMEWENN(INDIREKT($A11&"!A2:AE2");H$1;INDIREKT($A11&"!A3:AE3")))
B12 =WENN(ISTFEHLER(INDIREKT($A12&"!A1"));0;SUMMEWENN(INDIREKT($A12&"!A2:AE2");B$1;INDIREKT($A12&"!A3:AE3")))
C12 =WENN(ISTFEHLER(INDIREKT($A12&"!A1"));0;SUMMEWENN(INDIREKT($A12&"!A2:AE2");C$1;INDIREKT($A12&"!A3:AE3")))
D12 =WENN(ISTFEHLER(INDIREKT($A12&"!A1"));0;SUMMEWENN(INDIREKT($A12&"!A2:AE2");D$1;INDIREKT($A12&"!A3:AE3")))
E12 =WENN(ISTFEHLER(INDIREKT($A12&"!A1"));0;SUMMEWENN(INDIREKT($A12&"!A2:AE2");E$1;INDIREKT($A12&"!A3:AE3")))
F12 =WENN(ISTFEHLER(INDIREKT($A12&"!A1"));0;SUMMEWENN(INDIREKT($A12&"!A2:AE2");F$1;INDIREKT($A12&"!A3:AE3")))
G12 =WENN(ISTFEHLER(INDIREKT($A12&"!A1"));0;SUMMEWENN(INDIREKT($A12&"!A2:AE2");G$1;INDIREKT($A12&"!A3:AE3")))
H12 =WENN(ISTFEHLER(INDIREKT($A12&"!A1"));0;SUMMEWENN(INDIREKT($A12&"!A2:AE2");H$1;INDIREKT($A12&"!A3:AE3")))
B13 =WENN(ISTFEHLER(INDIREKT($A13&"!A1"));0;SUMMEWENN(INDIREKT($A13&"!A2:AE2");B$1;INDIREKT($A13&"!A3:AE3")))
C13 =WENN(ISTFEHLER(INDIREKT($A13&"!A1"));0;SUMMEWENN(INDIREKT($A13&"!A2:AE2");C$1;INDIREKT($A13&"!A3:AE3")))
D13 =WENN(ISTFEHLER(INDIREKT($A13&"!A1"));0;SUMMEWENN(INDIREKT($A13&"!A2:AE2");D$1;INDIREKT($A13&"!A3:AE3")))
E13 =WENN(ISTFEHLER(INDIREKT($A13&"!A1"));0;SUMMEWENN(INDIREKT($A13&"!A2:AE2");E$1;INDIREKT($A13&"!A3:AE3")))
F13 =WENN(ISTFEHLER(INDIREKT($A13&"!A1"));0;SUMMEWENN(INDIREKT($A13&"!A2:AE2");F$1;INDIREKT($A13&"!A3:AE3")))
G13 =WENN(ISTFEHLER(INDIREKT($A13&"!A1"));0;SUMMEWENN(INDIREKT($A13&"!A2:AE2");G$1;INDIREKT($A13&"!A3:AE3")))
H13 =WENN(ISTFEHLER(INDIREKT($A13&"!A1"));0;SUMMEWENN(INDIREKT($A13&"!A2:AE2");H$1;INDIREKT($A13&"!A3:AE3")))
B15 =SUMME(B2:B14)
C15 =SUMME(C2:C14)
D15 =SUMME(D2:D14)
E15 =SUMME(E2:E14)
F15 =SUMME(F2:F14)
G15 =SUMME(G2:G14)
H15 =SUMME(H2:H14)

Tabellendarstellung in Foren Version 4.11


Alles Andere würde einiges an Fummelei bedeuten, um das in eine Formel zu bekommen, wenn überhaupt möglich.
Gruß
David
Anzeige
Bedingte Summe über mehrere Blätter
08.07.2010 13:43:52
Erich
Hi Volker, (das war nicht schwer)
das ginge so:
 ABCDEFGH
1 MoDiMiDoFrSaSo
2Umsätze 1340135013701340140014301450

Formeln der Tabelle
ZelleFormel
B2{=SUMME(SUMMEWENN(INDIREKT(TEXT(DATUM(;ZEILE(1:2); 1); "MMMM")&"!A2:AE2"); B1; INDIREKT(TEXT(DATUM(;ZEILE(1:2); 1); "MMMM")&"!A3:AE3")))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Damit das richtig stimmte, musste ich erst noch die Leerzeichen hinter einigen Tagen ("Fr " statt "Fr") löschen.
Warum fängt Januar in Spalte A an, Februar in Spalte B?
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort in die Nachbarstadt (war auch nicht schwer)
Anzeige
AW: Bedingte Summe über mehrere Blätter
08.07.2010 14:02:25
reklov
Vielen Dank Erich,
habe ich noch mehr "Geheimnisse" offengelegt? Die Beantwortung gehört aber nicht ins Netz.
Ansonsten hat es geklappt!
Gruß reklov

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige