Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenn von verschiedenen Tabellen?

Betrifft: Summewenn von verschiedenen Tabellen? von: bocomtex
Geschrieben am: 03.09.2004 08:45:41

Hallo
Ich verwende die Summewennfunktion, wo Werte aus verschiedenen Tabellen
und Dateien gelesen werden. Sind alle benötigten Dateien offen ist alles o.k.
Aber wenn die Dateien mit den Tabellen geschlossen sind, habe ich den
Fehler #Wert.

=SUMMEWENN('P:\MONAT\PROFAERB\2004\[Septem04.XLS]HANDTÜCHER'!$A$5:$A$1000;37;'P:\MONAT\PROFAERB\2004\[Septem04.XLS]HANDTÜCHER'!$F$5:$F$1000)+SUMMEWENN('P:\MONAT\PROFAERB\2004\[Septem04.XLS]STOFFE'!$A$5:$A$1000;37;'P:\MONAT\PROFAERB\2004\[Septem04.XLS]STOFFE'!$F$5:$F$1000)+SUMMEWENN('P:\MONAT\PROFAERB\2004\[Septem04.XLS]HVL'!$A$5:$A$1000;37;'P:\MONAT\PROFAERB\2004\[Septem04.XLS]HVL'!$F$5:$F$1000)

Was ist falsch ?
Danke fü eine Antwort

Günter

  


Betrifft: SUMMEWENN und geschlossene Dateien von: Boris
Geschrieben am: 03.09.2004 09:25:48

Hi Günter,

falsch machst du gar nix - nur funktioniert SUMMEWENN eben nicht mit geschlossener Quelldatei (wie so viele andere Funktionen auch).
Ausweg: SUMMENPRODUKT - nach diesem Muster:

=SUMMENPRODUKT((A5:A1000=37)*F5:F1000)

Summiert alles aus Spalte F, wenn in Spalte A die 37 steht.
Das musst du nur noch um deine Pfadangaben ergänzen.
Funktioniert wunderbar mit geschlossenen Mappen.

Grüße Boris


  


Betrifft: Danke von: bocomtex
Geschrieben am: 03.09.2004 09:34:05

Danke für die schnelle Antwort.
Werde es damit versuchen!


Gruss
Günter


 

Beiträge aus den Excel-Beispielen zum Thema "Summewenn von verschiedenen Tabellen?"