Microsoft Excel

Herbers Excel/VBA-Archiv

Zeichen(um)verteilung auf mehrere Zellen

Betrifft: Zeichen(um)verteilung auf mehrere Zellen von: Joerschi
Geschrieben am: 10.10.2014 17:38:21

Hallo liebes Forum,

ich suche ein Lösung für folgendes Problem (Skizze unten):

Es gibt in der ersten Spalte eine Quell-Zahlenreihe bestehend aus (beispielsweise) 8 verschiedenen Ziffern (von 1 bis 9).
In eine nebenstehende Tabelle mit den Überschriften 1 bis 9 soll jetzt jeweils jede Zahl der Quell-Reihe separat unter ihrer Überschrift angezeigt werden. Fehlt eine Zahl in der Quellreihe, wird für deren Position ein "X" eingesetzt.

Für diese Verteilung unter die Überschriften suche ich eine Formellösung für den gelb markierten Bereich B3 bis J11.
Hätte jemand eine Idee, wo man ansetzen könnte?

Danke im Voraus!

Liebe Grüße
Joerschi

Skizze (ersten 3 Reihen schon manuell aufgeteilt...):


Beispieldatei: https://www.herber.de/bbs/user/93106.xlsx

  

Betrifft: Irreführend! Warum steht in J4 die 8 ? owT von: Matthias L
Geschrieben am: 10.10.2014 17:51:39




  

Betrifft: =WENN(ISTZAHL(FINDEN(B$2;$A3));B$2;"x") von: WF
Geschrieben am: 10.10.2014 17:57:42

in B3
nach rechts und nach unten kopieren

WF


  

Betrifft: AW: =WENN(ISTZAHL(FINDEN(B$2;$A3));B$2;"x") von: Joerschi
Geschrieben am: 10.10.2014 20:49:37

Danke WF,

Der Ansatz funktioniert einwandfrei.
Werd mich da reinarbeiten (da die Quell-Reihen teilweise auch noch aus bis zu 20 Zeichen bestehen können und aus Binominialverteilungen hervorgehen).

Alles Gute und LG
Joerschi


  

Betrifft: Ich vermute J4 sollte eine 9 sein ... von: Matthias L
Geschrieben am: 10.10.2014 18:06:12

Hallo

Hier mal mit einem kopierten Bereich

 ABCDEFGHIJ
13Quell-Reihe123456789
141234567812345678x
15123456791234567x9
1612345689123456x89
171234578912345x789

Formeln der Tabelle
ZelleFormel
B14=WENN(ISTFEHLER(FINDEN(B$13;$A14));"x";B$13)
C14=WENN(ISTFEHLER(FINDEN(C$13;$A14));"x";C$13)
D14=WENN(ISTFEHLER(FINDEN(D$13;$A14));"x";D$13)
E14=WENN(ISTFEHLER(FINDEN(E$13;$A14));"x";E$13)
F14=WENN(ISTFEHLER(FINDEN(F$13;$A14));"x";F$13)
G14=WENN(ISTFEHLER(FINDEN(G$13;$A14));"x";G$13)
H14=WENN(ISTFEHLER(FINDEN(H$13;$A14));"x";H$13)
I14=WENN(ISTFEHLER(FINDEN(I$13;$A14));"x";I$13)
J14=WENN(ISTFEHLER(FINDEN(J$13;$A14));"x";J$13)
B15=WENN(ISTFEHLER(FINDEN(B$13;$A15));"x";B$13)
C15=WENN(ISTFEHLER(FINDEN(C$13;$A15));"x";C$13)
D15=WENN(ISTFEHLER(FINDEN(D$13;$A15));"x";D$13)
E15=WENN(ISTFEHLER(FINDEN(E$13;$A15));"x";E$13)
F15=WENN(ISTFEHLER(FINDEN(F$13;$A15));"x";F$13)
G15=WENN(ISTFEHLER(FINDEN(G$13;$A15));"x";G$13)
H15=WENN(ISTFEHLER(FINDEN(H$13;$A15));"x";H$13)
I15=WENN(ISTFEHLER(FINDEN(I$13;$A15));"x";I$13)
J15=WENN(ISTFEHLER(FINDEN(J$13;$A15));"x";J$13)
B16=WENN(ISTFEHLER(FINDEN(B$13;$A16));"x";B$13)
C16=WENN(ISTFEHLER(FINDEN(C$13;$A16));"x";C$13)
D16=WENN(ISTFEHLER(FINDEN(D$13;$A16));"x";D$13)
E16=WENN(ISTFEHLER(FINDEN(E$13;$A16));"x";E$13)
F16=WENN(ISTFEHLER(FINDEN(F$13;$A16));"x";F$13)
G16=WENN(ISTFEHLER(FINDEN(G$13;$A16));"x";G$13)
H16=WENN(ISTFEHLER(FINDEN(H$13;$A16));"x";H$13)
I16=WENN(ISTFEHLER(FINDEN(I$13;$A16));"x";I$13)
J16=WENN(ISTFEHLER(FINDEN(J$13;$A16));"x";J$13)
B17=WENN(ISTFEHLER(FINDEN(B$13;$A17));"x";B$13)
C17=WENN(ISTFEHLER(FINDEN(C$13;$A17));"x";C$13)
D17=WENN(ISTFEHLER(FINDEN(D$13;$A17));"x";D$13)
E17=WENN(ISTFEHLER(FINDEN(E$13;$A17));"x";E$13)
F17=WENN(ISTFEHLER(FINDEN(F$13;$A17));"x";F$13)
G17=WENN(ISTFEHLER(FINDEN(G$13;$A17));"x";G$13)
H17=WENN(ISTFEHLER(FINDEN(H$13;$A17));"x";H$13)
I17=WENN(ISTFEHLER(FINDEN(I$13;$A17));"x";I$13)
J17=WENN(ISTFEHLER(FINDEN(J$13;$A17));"x";J$13)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: steht doch genau drüber von: WF
Geschrieben am: 10.10.2014 18:44:50

.


  

Betrifft: ja klar stehts genau drüber ... von: Matthias L
Geschrieben am: 10.10.2014 19:00:15

Hallo

In J4 steht im Bsp. eine 8
Ich habe diesbezüglich ja nachgefragt!

Drüber steht aber die 9 in J2
Deshalb hatte ich vermutet das dort die 9 hingehört

Gruß Matthias


  

Betrifft: ich meinte mich von: WF
Geschrieben am: 10.10.2014 19:08:40

.


  

Betrifft: AW: ja klar stehts genau drüber ... von: Joerschi
Geschrieben am: 10.10.2014 20:14:25

sorry Matthias., Du hast Recht.
Das sollte eine 9 sein.
Fehler durch händisches Eintragen :-( (deswegen allein machen Formeln schon Sinn - Stichwort Fehleranfälligkeit)

Dennoch Danke für Dein Engagement!
Joerschi


 

Beiträge aus den Excel-Beispielen zum Thema "Zeichen(um)verteilung auf mehrere Zellen"