Microsoft Excel

Herbers Excel/VBA-Archiv

Zeichenfolge in Zelle finden und Aktion ausführen

Betrifft: Zeichenfolge in Zelle finden und Aktion ausführen von: Thomas Weiß
Geschrieben am: 04.01.2006 16:42:08

Hallo Excel-Experten.

Ich habe folgende Aufgabe zu erfüllen und stecke wohl in einer Sackgasse:

Kommt eine bestimmte Zeichenfolge (aaa) in einer Zelle (z.B. A1) vor, soll der Wert aus Zelle A10 in Zelle A5 kopiert werden. Dies soll für A1 bis An möglich sein.

Folgendes habe ich in Zelle A5 geschrieben: =WENN(FINDEN("(aaa)";A1;1);A10).

Steht die Zeichenfolge „aaa“ in Zelle A1, passiert was passieren soll (der Wert von A10 landet in Zelle A5).
Steht die Zeichenfolge jedoch nicht in Zelle A1, wird der Fehlerwert #WERT! In die Zelle geschrieben – das will ich vermeiden, die Zelle soll leer sein.

Ich weiß das es daran liegt, dass die FINDEN und auch die SUCHEN Funktion als Ergebnis anzeigt, an welcher Stelle die gesuchte Zeichenfolge in der Zelle beginnt. Ist sie nicht da, gibt’s den Fehlerwert.

Hat jemand eine Idee wie ich das lösen kann?
Meine VB-Kentnisse liegen bei knapp über Null.

Vielen Dank für Eure Hilfe und ein gutes neues Jahr!

Thomas

  


Betrifft: istzahl(finden()) von: ransi
Geschrieben am: 04.01.2006 16:45:13

hallo thomas

das kannst du so abfangen:
=wenn(istzahl(finden());dann;sonst)

ransi


  


Betrifft: AW: istzahl(finden()) von: Thomas Weiß
Geschrieben am: 08.01.2006 17:17:10

Danke für den Tipp!

Es hat geklappt!


  


Betrifft: AW: Zeichenfolge in Zelle finden und Aktion ausführen von: Dr.
Geschrieben am: 04.01.2006 16:45:42

Hi,

bastel noch ein

=WENN(ISTFEHLER(deineformel);"";deineformel)

drumherum.


  


Betrifft: AW: Zeichenfolge in Zelle finden und Aktion ausfüh von: Thomas Weiß
Geschrieben am: 08.01.2006 17:18:00

Danke für den Tipp!

Es hat geklappt!


 

Beiträge aus den Excel-Beispielen zum Thema "Zeichenfolge in Zelle finden und Aktion ausführen"