Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

Tabellenname enthalten | Herbers Excel-Forum


Betrifft: Tabellenname enthalten von: Sibylle Weber
Geschrieben am: 20.11.2009 21:22:22

Hallo,

in A1 wird ein Tabellenname eingetragen.
Wie kann man feststellen, ob dieser Tabellenname in der Mappe enthalten ist?
Über eine Beantwortung der Frage würde ich mich sehr freuen.
Gruß
Sibylle

  

Betrifft: AW: Tabellenname enthalten von: Josef Ehrensberger
Geschrieben am: 20.11.2009 21:30:11

Hallo Sybille,

mit einem definierten Namen geht das.

Tabelle1

 AB
1Tabelle2Gibt's
2Tabelle3Gibt's
3Tabelle5Gibt's nicht

Formeln der Tabelle
ZelleFormel
B1{=WENN(ISTZAHL(VERGLEICH(A1;TEIL(Tabellen;FINDEN("]";Tabellen)+1;32); 0)); "Gibt's";"Gibt's nicht")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen
Namen in Formeln
ZelleNameBezieht sich auf
B1Tabellen=ARBEITSMAPPE.ZUORDNEN(1)
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Tabellenname enthalten von: Sibylle Weber
Geschrieben am: 20.11.2009 22:03:12

Hallo Sepp,

ich danke Dir für die rasche Antwort.
Entschuldige bitte. Ich suchte eine VBA-Lösung.
Hast Du einen Vorschlag?
Gruß
Sibylle


  

Betrifft: AW: Tabellenname enthalten von: Josef Ehrensberger
Geschrieben am: 20.11.2009 22:54:05

Hallo Sibylle,

kein Problem.

Public Function SheetExist(ByVal sheetName As String, Optional Wb As Workbook) As Boolean
  Dim wks As Worksheet
  On Error GoTo ERRORHANDLER
  If Wb Is Nothing Then Set Wb = ThisWorkbook
  For Each wks In Wb.Worksheets
    If wks.Name = sheetName Then SheetExist = True: Exit Function
  Next
  ERRORHANDLER:
  SheetExist = False
End Function

Sub test()
  If SheetExist(Sheets("Tabelle1").Range("a1")) Then
    MsgBox "Gibt's"
  Else
    MsgBox "Gibt's nicht"
  End If
End Sub


Die Funktion kannst du auch als Formel in der Tabelle einsetzen.

Tabelle1

 AB
1Tabelle2WAHR
2Tabelle3WAHR
3Tabelle5FALSCH

Formeln der Tabelle
ZelleFormel
B1=sheetexist(A1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






Gruß Sepp



  

Betrifft: AW: Tabellenname enthalten von: Sibylle Weber
Geschrieben am: 21.11.2009 17:14:38

Hallo Sepp,

ich danke Dir für Deine Beiträge.
Damit ist das Problem gelöst.
Vielen Dank.

Gruß
Sibylle


Beiträge aus den Excel-Beispielen zum Thema "Tabellenname enthalten"