Vergleich mit variablen Tabellennamen

Bild

Betrifft: Vergleich mit variablen Tabellennamen
von: Peter Stähler
Geschrieben am: 16.03.2005 16:53:00
Hallo zusammen,
bei einem Problem komme ich nicht weiter und bitte um Eure Hilfe.
In einer Arbeitsmappe sind mehrere Tabellen mit auszuwertenden Daten vorhanden. Diese heißen D1, D2, D3, ...
Auf einer Ergebnistabelle möchte ich nun Werte aus diesen Datentabellen anzeigen. Dazu möchte ich auf dieser Ergebnistabelle in einer Zelle den Namen der Datentabelle angeben (z.B. D2) und dann die Daten aus dieser Tabelle in die Ergebnistabelle holen.
Kompliziert wird es für mich auch dadurch, daß ich auf die Datentabellen mit der Funktion VERGLEICH arbeiten muß da ich nicht genau weiß wo in diesen Datentabellen meine Daten stehen.
Bin für jede Hilfe dankbar.
Schon im Voraus vielen Dank und viele Grüße
Peter

Bild

Betrifft: AW: Vergleich mit variablen Tabellennamen
von: ransi
Geschrieben am: 16.03.2005 16:59:05
hallo peter
das hört sich nach einer kombination von:
indirekt()
index()
und
vergleich() an.
aber ohne beispieldatei schwer zu sagen...
ransi
Bild

Betrifft: AW: Vergleich mit variablen Tabellennamen
von: Peter Stähler
Geschrieben am: 16.03.2005 17:05:58
Hallo Ransi,
hier ist eine Beispieldatei
https://www.herber.de/bbs/user/19752.xls
Vielen Dank für Deine Hilfe
Gruß
Peter
Bild

Betrifft: ==SVERWEIS(B9;INDIREKT($C$4&"!a4:b8");..)
von: ransi
Geschrieben am: 16.03.2005 17:15:50
hallo peter
indirekt() + sverweis() ist es !
schau mal hier:
 
 BC
4Tabellennamexx
5  
6  
7  
8  
9Produkt_180
10Produkt_250
11Produkt_360
12Produkt_490
13Produkt_540
Formeln der Tabelle
C9 : =SVERWEIS(B9;INDIREKT($C$4&"!a4:b8");2;FALSCH)
C10 : =SVERWEIS(B10;INDIREKT($C$4&"!a4:b8");2;FALSCH)
C11 : =SVERWEIS(B11;INDIREKT($C$4&"!a4:b8");2;FALSCH)
C12 : =SVERWEIS(B12;INDIREKT($C$4&"!a4:b8");2;FALSCH)
C13 : =SVERWEIS(B13;INDIREKT($C$4&"!a4:b8");2;FALSCH)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
musst in deiner datei aber noch den bereich erweitern.
ransi
Bild

Betrifft: Super
von: Peter Stähler
Geschrieben am: 16.03.2005 17:21:27
Hallo Ransi
und vielen Dank ...
Genau so sollte es sein.
Einen schönen Frühlingsabend wünsch' ich Dir.
Viele Grüße
Peter
Bild

Betrifft: Kleine Ergänzung:
von: Boris
Geschrieben am: 16.03.2005 17:24:59
Hi Peter,
...sofern deine Blattnamen in "Realo" auch Leerzeichen enthalten können, dann musst du dies bei der indirekten Referenzierung berücksichtigen, indem du die Hochkommata dazusetzt:
=SVERWEIS(B9;INDIREKT("'"&$C$4&"'!A:B");2;)
Grüße Boris
Bild

Betrifft: @Boris
von: ransi
Geschrieben am: 16.03.2005 20:02:40
hallo boris
kannst du mir erklären warum indirekt() schwierigkeiten macht wenn Leerzeichen im
tabellenblattname enthalten sind?
wo kommt das hochkomma dann aufeinmal her?
ransi
Bild

Betrifft: Schau dir doch einfach mal einen normalen Bezug an
von: Boris
Geschrieben am: 16.03.2005 20:30:01
Hi Ransi,
vorhanden: 2 Blätter. Eines trägt den Namen OhneLeerzeichen, das andere den Namen Mit Leerzeichen
Nimm jetzt einfach mal Bezug auf A1 der beiden Blätter:
 
 A
10
20
Formeln der Tabelle
A1 : =OhneLeerzeichen!A1
A2 : ='Mit Leerzeichen'!A1
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Fällt Dir was auf?
Irgendwie muss Excel doch erkennen, dass es sich bei dem Namen mit Leerzeichen um einen zusammengehörigen Namen handelt.
Denn ein bloßes Leerzeichen hat ja in Excel bereits die Schnittmengenfunktion.
Na ja - und das gilt dann halt auch logischerweise für INDIREKT.
Grüße Boris
Bild

Betrifft: AW: Schau dir doch einfach mal einen normalen Bezug an
von: ransi
Geschrieben am: 16.03.2005 20:42:29
hallo boris
bin bis jetzt immer davon ausgegangen:
das leerzeichen in einem string wird genauso behandelt wie jeder andere buchstabe oder jede andere zahl.
das es da probleme geben kann, ist mir neu.
danke für die erklärung.
ransi
Bild

Betrifft: Nicht verallgemeinern...
von: Boris
Geschrieben am: 16.03.2005 21:31:51
Hi Ransi,
...das bezieht sich auf den String, der an die Funktion INDIREKT übergeben wird - und die Funktion macht ja dann wieder einen Bezug draus - und wie ein Bezug mit Leerzeichen auszusehen hat, hab ich dir ja mit der Jeanie visualisiert.
Grüße Boris
Bild

Betrifft: freut mich wenns klappt, dir auch. o,T.
von: ransi
Geschrieben am: 16.03.2005 17:24:53

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Vergleich mit variablen Tabellennamen"