Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis + Links Funktion (#NV) | Herbers Excel-Forum


Betrifft: Sverweis + Links Funktion (#NV) von: FM
Geschrieben am: 18.01.2010 11:29:57

Hallo,

ich habe ein kleines Problem mit der Sverweis Funktion.
Ich habe in einer Spalte z.b. den Wert 4934255. Die ersten 2 Zahlen determinieren den Typ. 40 in dem Fall PKW.
Nun habe ich eine Zusatzspalte gemacht mit 'links(a1;2) um nur den Wert 49 in dieser Spalte zu haben.
In einem zweiten Sheet habe ich die Sverweis-Matrix in der z.b. steht:

Spalte A Spalte B
49 PKW

Wenn ich nun die Sverweis-Formel erstelle:
'sverweis(A2;Tabelle2!$A$1:$B:$1;2;Falsch) bekomme ich den Wert #NV geliefert.
Wenn ich spasseshalber in der A2 den Wert 49 manuell eingebe, bekomme ich den richtigen Sverweis (PKW).
Woran liegt das? Kann man eine Sverweis Formel nicht mit der Links Formel vorneweg verknüpfen?

Danke in Voraus
Florian

  

Betrifft: Links() ist Text - ergo mit 1 multiplizieren von: WF
Geschrieben am: 18.01.2010 11:54:39

.


  

Betrifft: AW: Links() ist Text - ergo mit 1 multiplizieren von: FM
Geschrieben am: 18.01.2010 11:56:25

Danke !


  

Betrifft: AW: Sverweis + Links Funktion (#NV) von: BerndE
Geschrieben am: 18.01.2010 11:56:15

Hallo Florian,

die LINKS-Funktion gibt einen String zurück. Du musst also SVERWEIS(WERT(A2);..... verwenden.

Gruß
Bernd
http://www.bernds.page.de.vu


  

Betrifft: AW: Sverweis + Links Funktion (#NV) von: Bosko Biati
Geschrieben am: 18.01.2010 11:56:45

Hallo,

so:

Tabelle1

 ABCD
14953405  
2483266  
34795217 5
46235108 5

Formeln der Tabelle
ZelleFormel
D3{=SVERWEIS("49";LINKS($A$1:$B$12;2); 2;0)}
D4{=SVERWEIS(49;LINKS($A$1:$B$12;2)*1;2;0)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß

Bosko


Beiträge aus den Excel-Beispielen zum Thema "Sverweis + Links Funktion (#NV)"