kleiner Balken in Zelle

Bild

Betrifft: kleiner Balken in Zelle
von: Christian
Geschrieben am: 02.03.2005 11:13:19
Hallo,
ich weiß nicht, ob so etwas möglich ist...
Ich möchte einen Balken / dicke Linie in einer Zelle darstellen, wobei die Länge des Balkens abhängig von der Größe eines Wertes einer anderen Zelle ist.
der Wert schwankt zwischen 2 und 3. Bei 2 soll der Balken kaum zu swehen sein, bei 3 maximal. Eben ein kleines Diagramm. Aber ich möchte KEIN Diagramm erstellen.
Das soll dem schnellen Überblick dienen...
MfG
Christian

Bild

Betrifft: AW: kleiner Balken in Zelle
von: =Peter=
Geschrieben am: 02.03.2005 11:29:12
Hallo Christian,
vielleicht hilft dir das als Ansatz weiter:
Tabelle1
 AB
13#########
22##
Formeln der Tabelle
B1 : =WENN(A1=3;"#########";WENN(A1=2;"##";""))
B2 : =WENN(A2=3;"#########";WENN(A2=2;"##";""))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruss
Peter
Bild

Betrifft: AW: kleiner Balken in Zelle
von: Margarete
Geschrieben am: 02.03.2005 12:14:59
Hallo Christian,
ich habe folgende Formel für Dich:
=WENN(A1=2;"g";WENN(A1=3;"ggg";""))
Wenn Du das kleine "g" mit Webdings formatierst, bekommst Du einen Balken.
Gruß
Margarete
Bild

Betrifft: AW: kleiner Balken in Zelle
von: Christian
Geschrieben am: 02.03.2005 12:20:59
Danke für Eure AWs..
Ich habe es jetzt so gelöst:

Function sicherheit(eta) As String
Dim zeichen As String
zeichen = "g"
Select Case eta
 Case Is < 1.75
 sicherheit = ""
 Case 1.75 To 1.92
 sicherheit = String(1, zeichen)
 Case 1.92 To 2.08
 sicherheit = String(2, zeichen)
 Case 2.08 To 2.25
 sicherheit = String(3, zeichen)
 Case 2.25 To 2.42
 sicherheit = String(4, zeichen)
 Case 2.42 To 2.58
 sicherheit = String(5, zeichen)
 Case Is > 2.58
 sicherheit = String(6, zeichen)
End Select
End Function

So ist das Ergebnis:
 
 HIJKL
84 6602,44 190 733      ggggg
93 8111,95 157 251      gg
103 6931,88 138 400      g
113 7431,91 142 790      g
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Ich bin begeistert. So habe ich mir das vorgestellt !!!
MfG
Christian
 Bild

Beiträge aus den Excel-Beispielen zum Thema "kleiner Balken in Zelle"