Microsoft Excel

Herbers Excel/VBA-Archiv

Liste in Zelle darstellen

Betrifft: Liste in Zelle darstellen von: Tobiax
Geschrieben am: 11.09.2014 19:12:48

Hallo!

Folgende Vorrausetzung:
Tabelle1, Spalte A stehen verschiedene Anlagenteil. Jeder Wert existiert nur 1x.
Tabelle2, Spalte C stehen ebenfalls diese Anlagenteile. Jeder Wert kann mehrfach vorhanden sein.
Tabelle2, Spalte D stehen Aufgaben

Nun die Aufgabe, die ich mit eurer Hilfe lösen muss
Beispiel:
In Tabelle1, Spalte A2 steht "Turm".
In die Zelle E2 sollen nun alle "Turm" Aufgaben (jeweils neue Zeile) aus Tabelle2, Spalte D stehen

Ich hoffe das war verständlich und jemand kann mir helfen.

Tobiax...

  

Betrifft: AW: Liste in Zelle darstellen von: Daniel
Geschrieben am: 11.09.2014 19:26:53

Hi
1. Spalte C und D nach C sortieren, so dass alle Aufgaben zu einem Anlagenteil direkt untereinander stehen.

2. in Spalte F folgende Formel (Formel für F2): =WENN(C2=C3;D2&ZEICHEN(10)&F3;D2)
Formel so weit nach unten ziehen wie in C und D Daten stehen

3. in E2 folgende Formel: =SVerweis(A2;C:F;4;0)
(zeilenumbruch im Format aktivieren)

wenn umsortiert werden muss, Formeln durch Werte ersetzen.

Gruß Daniel


  

Betrifft: AW: Liste in Zelle darstellen von: Tobiax
Geschrieben am: 11.09.2014 19:48:49

Super!

DANKE !!!!!


  

Betrifft: AW: Liste in Zelle darstellen von: Tobiax
Geschrieben am: 11.09.2014 20:08:05

Hallo!

Das von Daniel funktioniert.
Aber leider kann ich nicht nach Spalte C sortieren, da es eine chronologische Liste ist.

Es würde mit einem Klick auf ein Makro gehen, aber kann man das umgehen?

Tobiax...


  

Betrifft: AW: Liste in Zelle darstellen von: Daniel
Geschrieben am: 11.09.2014 21:34:25

HI
ohne sortieren werden die Formeln sehr aufwendig, wenn du reine Excelformeln verwenden willst.
Rechnen kann Excel sehr gut, aber beim Umgang mit Texten hapert es noch etwas.
Eine Funktion, die Texte mit Bedingung ähnilch einem SummeWenn gibt es noch nicht.

Wenn du aber mit Makros umgehen kannst, könntest du dir eine entsprechende Funktion selber schreiben.
Such mal im Herber-Archiv nach SVerweis2, da findest du entsprechende Codebeispiele.

Gruß Daniel


  

Betrifft: AW: Liste in Zelle darstellen von: Tobiax
Geschrieben am: 11.09.2014 21:47:00

Hallo!

Das habe ich mir schon gedacht. Schade. Ein Makro zum sortieren bekomme ich ach noch leicht hin.
Erstmal DANKE.

Aber dann stelle ich noch eine dritte Frage.

Wie bekomme ich es denn ohne Makro hin, daß nur die Aufgaben in meiner Liste stehen, die als Datum heute oder früher sind?
Wahrscheinlich muss ich da mit einer Hilfsliste arbeiten, oder?

Tobiax...


  

Betrifft: AW: Liste in Zelle darstellen von: Daniel
Geschrieben am: 11.09.2014 22:02:49

HI
nach meinem aktuellen Kenntnisstand deiner Datei kannst du das Problem gar nicht lösen, weil nirgendwo ein Datum steht.

sollte das gewünschte Ausführungsdatum in Spalte B stehen, könntest du das Datum als zusätzliche Bedingung mit in die Formel aufnehmen (Formel für F2):

=WENN(B2<=HEUTE();D2&ZEICHEN(10);"")&WENN(C2=C3;F3;"")
Gruß Daniel


  

Betrifft: AW: Liste in Zelle darstellen von: Tobiax
Geschrieben am: 12.09.2014 07:13:04

Danke, habe es mir so gebastelt, daß es passt.


 

Beiträge aus den Excel-Beispielen zum Thema "Liste in Zelle darstellen"